{"answers":{"affected":"2 open source packages ship an affected version, including phpmyadmin/phpmyadmin. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2018-12613 exists.","fix":"Upgrade phpmyadmin/phpmyadmin to 4.8.2 or later.","what":"CVE-2018-12613 is a high-severity path traversal vulnerability in Phpmyadmin Phpmyadmin, published on 21 Jun 2018. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2018-12613 and fix it if it is affected.\n\nWhat it is: CVE-2018-12613 is a high-severity path traversal vulnerability in Phpmyadmin Phpmyadmin, published on 21 Jun 2018. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2018-12613 exists.\n\nAffected packages and fixed versions:\n- phpmyadmin/phpmyadmin (Packagist): affected from 4.8; fixed in 4.8.2\n- phpmyadmin/phpmyadmin (Packagist): affected from 4.8; fixed in 4.8.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2018-12613/ (Markdown: https://insights.sbomify.com/CVE-2018-12613/index.md)","id":"CVE-2018-12613","markdown":"https://insights.sbomify.com/CVE-2018-12613/index.md","name":"CVE-2018-12613","record":{"aliases":["GHSA-x394-g9j8-x7mf"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","data_read"],"network_reachable":"yes","non_default_config":true,"product_category":"phpMyAdmin database tool","requires_auth":"low_privilege","summary":"Authenticated attackers can include arbitrary files to execute code or read data, with unauthenticated access possible under specific non-default configurations.","user_interaction":"not_required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"phpmyadmin","vendor":"phpmyadmin"}],"cvss":{"score":8.8,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-287","name":"Improper Authentication"}],"description":"An issue was discovered in phpMyAdmin 4.8.x before 4.8.2, in which an attacker can include (view and potentially execute) files on the server. The vulnerability comes from a portion of code where pages are redirected and loaded within phpMyAdmin, and an improper test for whitelisted pages. An attacker must be authenticated, except in the \"$cfg['AllowArbitraryServer'] = true\" case (where an attacker can specify any host he/she is already in control of, and execute arbitrary code on phpMyAdmin) and the \"$cfg['ServerDefault'] = 0\" case (which bypasses the login requirement and runs the vulnerable code without any authentication).","ecosystems":["Packagist"],"exploits":{"exploitdb":5,"first_seen":"2018-06-19","github_poc":4,"max_poc_stars":10,"metasploit":1,"nuclei":1,"refs":[{"date":"2018-11-09T14:10:20Z","kind":"github_poc","ref":"https://github.com/0x00-0x00/CVE-2018-12613","stars":10,"title":"PHPMyAdmin v4.8.0 and v.4.8.1 LFI exploit"},{"date":"2019-09-16T12:14:52Z","kind":"github_poc","ref":"https://github.com/ivanitlearning/CVE-2018-12613","stars":4,"title":"Modified standalone exploit ported for Python 3"},{"date":"2020-02-19T05:41:11Z","kind":"github_poc","ref":"https://github.com/eastmountyxz/CVE-2018-12613-phpMyAdmin","stars":2,"title":"这篇文章将分享一个phpMyAdmin 4.8.1版本的文件包含漏洞，从配置到原理，再到漏洞复现进行讲解，更重要的是让大家了解这些真实漏洞背后的知识。基础性文章，希望对您有所帮助！"},{"date":"2018-06-19","kind":"metasploit","ref":"exploit/multi/http/phpmyadmin_lfi_rce","stars":null,"title":"phpMyAdmin Authenticated Remote Code Execution"},{"date":"2018-06-21","kind":"exploitdb","ref":"44924","stars":null,"title":"phpMyAdmin 4.8.1 - (Authenticated) Local File Inclusion (1)"},{"date":"2018-06-22","kind":"exploitdb","ref":"44928","stars":null,"title":"phpMyAdmin 4.8.1 - (Authenticated) Local File Inclusion (2)"},{"date":"2018-07-13","kind":"exploitdb","ref":"45020","stars":null,"title":"phpMyAdmin - (Authenticated) Remote Code Execution (Metasploit)"},{"date":"2018-07-13","kind":"exploitdb","ref":"45020","stars":null,"title":"phpMyAdmin - (Authenticated) Remote Code Execution (Metasploit)"}],"tier":"weaponised"},"has_fix":true,"headline":"phpMyAdmin Improper Authentication","id":"CVE-2018-12613","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":"phpmyadmin:phpmyadmin","products":["phpmyadmin:phpmyadmin"],"type":"path_traversal","year":"2018"},"n_packages":2,"n_references":7,"next":{"headline":"Phusion Passenger incorrect permission assignment","id":"CVE-2018-12615"},"packages":[{"ecosystem":"Packagist","fixed":["4.8.2"],"introduced":["4.8"],"last_affected":[],"package":"phpmyadmin/phpmyadmin","purl":null,"source":"GHSA-x394-g9j8-x7mf"},{"ecosystem":"Packagist","fixed":["4.8.2"],"introduced":["4.8"],"last_affected":[],"package":"phpmyadmin/phpmyadmin","purl":"pkg:composer/phpmyadmin/phpmyadmin","source":"GHSA-x394-g9j8-x7mf"}],"prev":{"headline":"Path traversal in n/a","id":"CVE-2018-12611"},"products":["n/a"],"published":"2018-06-21","related":[{"cvss_score":10,"headline":"Misconfiguration in n/a","id":"CVE-2008-7251","kev_date_added":null,"published":"2010-01-19"},{"cvss_score":10,"headline":"phpMyAdmin unsafely handles temporary files","id":"CVE-2008-7252","kev_date_added":null,"published":"2010-01-19"},{"cvss_score":10,"headline":"Other in n/a","id":"CVE-2007-0203","kev_date_added":null,"published":"2007-01-11"},{"cvss_score":10,"headline":"Command injection in n/a","id":"CVE-2004-1147","kev_date_added":null,"published":"2004-12-15"},{"cvss_score":9.8,"headline":"phpmyadmin contains SQL Injection vulnerability","id":"CVE-2020-22452","kev_date_added":null,"published":"2023-01-26"},{"cvss_score":9.8,"headline":"phpMyAdmin SQL injection in Designer feature","id":"CVE-2019-11768","kev_date_added":null,"published":"2019-06-05"},{"cvss_score":9.8,"headline":"phpMyAdmin SQL injection in Designer feature","id":"CVE-2019-6798","kev_date_added":null,"published":"2019-01-26"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"attribution","licence":"BSD-3-Clause","name":"Metasploit"},{"class":"attribution","licence":"GPL-2.0-or-later","name":"Exploit-DB"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"Authenticated attackers can include arbitrary files to execute code or read data, with unauthenticated access possible under specific non-default configurations.","url":"https://insights.sbomify.com/CVE-2018-12613/"}