{"answers":{"affected":"2 open source packages ship an affected version, including passenger. It affects 1 product.","exploited":"There is no known exploitation of CVE-2018-12615 in the wild and no public exploit code.","fix":"Upgrade passenger to 5.3.2 or later.","what":"CVE-2018-12615 is a medium-severity vulnerability in n/a, published on 21 Jun 2018. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2018-12615 and fix it if it is affected.\n\nWhat it is: CVE-2018-12615 is a medium-severity vulnerability in n/a, published on 21 Jun 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2018-12615 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- passenger (RubyGems): affected all versions; fixed in 5.3.2\n- passenger (RubyGems): affected all versions; fixed in 5.3.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2018-12615/ (Markdown: https://insights.sbomify.com/CVE-2018-12615/index.md)","id":"CVE-2018-12615","markdown":"https://insights.sbomify.com/CVE-2018-12615/index.md","name":"CVE-2018-12615","record":{"aliases":["GHSA-4284-jfhc-f854"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["privilege_escalation"],"network_reachable":"yes","non_default_config":false,"product_category":"Phusion Passenger","requires_auth":"none","summary":"Improper group initialization in Phusion Passenger allows attackers to gain unauthorized privileges due to uninitialized memory usage during privilege lowering.","user_interaction":"not_required","vuln_class":"privilege_escalation"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"passenger","vendor":"phusion"}],"cvss":{"score":5.3,"severity":"medium","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N","version":"3.0"},"cwes":[{"id":"CWE-732","name":"Incorrect Permission Assignment for Critical Resource"}],"description":"An issue was discovered in switchGroup() in agent/ExecHelper/ExecHelperMain.cpp in Phusion Passenger before 5.3.2. The set of groups (gidset) is not set correctly, leaving it up to randomness (i.e., uninitialized memory) which supplementary groups are actually being set while lowering privileges.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Phusion Passenger incorrect permission assignment","id":"CVE-2018-12615","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":"privilege_escalation","year":"2018"},"n_packages":2,"n_references":1,"next":{"headline":"Integer overflow in n/a","id":"CVE-2018-12617"},"packages":[{"ecosystem":"RubyGems","fixed":["5.3.2"],"introduced":["0"],"last_affected":[],"package":"passenger","purl":null,"source":"GHSA-4284-jfhc-f854"},{"ecosystem":"RubyGems","fixed":["5.3.2"],"introduced":["0"],"last_affected":[],"package":"passenger","purl":"pkg:gem/passenger","source":"GHSA-4284-jfhc-f854"}],"prev":{"headline":"phpMyAdmin Improper Authentication","id":"CVE-2018-12613"},"products":["n/a"],"published":"2018-06-21","related":[{"cvss_score":9.8,"headline":"Phusion Passenger SpawningKit Contains Arbitrary Read/Write Vulnerability","id":"CVE-2018-12026","kev_date_added":null,"published":"2018-06-17"},{"cvss_score":8.8,"headline":"Insecure Permissions in Phusion Passenger","id":"CVE-2018-12027","kev_date_added":null,"published":"2018-06-17"},{"cvss_score":7.8,"headline":"Incorrect Access Control in Phusion Passenger","id":"CVE-2018-12028","kev_date_added":null,"published":"2018-06-17"},{"cvss_score":7.8,"headline":"Phusion Passenger uses a known /tmp filename","id":"CVE-2016-10345","kev_date_added":null,"published":"2017-04-18"},{"cvss_score":7.5,"headline":"RubyGems passenger gem allows remote attackers to delete files","id":"CVE-2012-6135","kev_date_added":null,"published":"2019-11-19"},{"cvss_score":5.3,"headline":"Phusion Passenger denial of service","id":"CVE-2025-26803","kev_date_added":null,"published":"2025-02-24"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-17","vendors":["n/a"]},"summary":"Improper group initialization in Phusion Passenger allows attackers to gain unauthorized privileges due to uninitialized memory usage during privilege lowering.","url":"https://insights.sbomify.com/CVE-2018-12615/"}