# CVE-2018-1272: Possible privilege escalation in org.springframework:spring-core

> Attackers can inject extra multipart data in proxied requests to cause server B to use wrong values, potentially leading to privilege escalation.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Apr 2018
- **Updated:** 17 Sep 2024
- **Also known as:** DEBIAN-CVE-2018-1272, GHSA-4487-x383-qpph, ROOT-APP-MAVEN-CVE-2018-1272

## What is CVE-2018-1272?

CVE-2018-1272 is a high-severity vulnerability in Oracle Application Testing Suite, published on 6 Apr 2018. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Spring Framework, versions 5.0 prior to 5.0.5 and versions 4.3 prior to 4.3.15 and older unsupported versions, provide client-side support for multipart requests. When Spring MVC or Spring WebFlux server application (server A) receives input from a remote client, and then uses that input to make a multipart request to another server (server B), it can be exposed to an attack, where an extra multipart is inserted in the content of the request from server A, causing server B to use the wrong value for a part it expects. This could to lead privilege escalation, for example, if the part content represents a username or user roles.

## Which versions are affected by CVE-2018-1272?

4 open source packages ship an affected version, including org.springframework:spring-core. It affects 25 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.springframework:spring-core` | Maven | All versions | 4.3.15 |
| `org.springframework:spring-core` | Maven | All versions | 4.3.15 |
| `org.springframework:spring-core` | Maven | From 5.0.0 | 5.0.5 |
| `org.springframework:spring-core` | Maven | From 5.0.0 | 5.0.5 |

Products: Oracle Application Testing Suite, Oracle Big Data Discovery, Oracle Communications Converged Application Server, Oracle Communications Diameter Signaling Router, Oracle Communications Performance Intelligence Center, Oracle Communications Services Gatekeeper, Oracle Enterprise Manager Ops Center, Oracle Goldengate for Big Data, Oracle Health Sciences Information Manager, Oracle Healthcare Master Person Index, Oracle Insurance Calculation Engine, Oracle Insurance Rules Palette, Oracle Primavera Gateway, Oracle Retail Back Office, Oracle Retail Central Office, Oracle Retail Customer Insights, Oracle Retail Integration Bus, Oracle Retail Open Commerce Platform, Oracle Retail Order Broker, Oracle Retail Point-of-Sale and 5 more.

## How do I fix CVE-2018-1272?

Upgrade org.springframework:spring-core to a fixed version for your release line: 4.3.15 or 5.0.5.

## Is CVE-2018-1272 being exploited?

There is no known exploitation of CVE-2018-1272 in the wild and no public exploit code.

## Other vulnerabilities in Oracle Application Testing Suite

- [CVE-2026-35290](https://insights.sbomify.com/CVE-2026-35290/): Auth bypass in Oracle Application Testing Suite (critical 9.8)
- [CVE-2026-46876](https://insights.sbomify.com/CVE-2026-46876/): Auth bypass in Oracle Application Testing Suite (critical 9.8)
- [CVE-2026-46924](https://insights.sbomify.com/CVE-2026-46924/): Auth bypass in Oracle Application Testing Suite (critical 9.8)
- [CVE-2019-2904](https://insights.sbomify.com/CVE-2019-2904/): Auth bypass in Enterprise Repository (critical 9.8)
- [CVE-2018-1275](https://insights.sbomify.com/CVE-2018-1275/): Spring Framework has Improperly Implemented Security Check for Standard (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-1272 and fix it if it is affected.

What it is: CVE-2018-1272 is a high-severity vulnerability in Oracle Application Testing Suite, published on 6 Apr 2018. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-1272 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.springframework:spring-core (Maven): affected all versions; fixed in 4.3.15
- org.springframework:spring-core (Maven): affected all versions; fixed in 4.3.15
- org.springframework:spring-core (Maven): affected from 5.0.0; fixed in 5.0.5
- org.springframework:spring-core (Maven): affected from 5.0.0; fixed in 5.0.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-1272/ (Markdown: https://insights.sbomify.com/CVE-2018-1272/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-1272
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-1272
- OSV: https://osv.dev/vulnerability/CVE-2018-1272

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-1272/
Summaries are generated and may contain mistakes; the official description above is the record.
