# CVE-2018-1274: Spring Data Commons contain a property path parser vulnerability caused by unlimited resource allocation

> Unauthenticated attackers can cause denial of service via resource exhaustion in Spring Data Commons property path parsing.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Apr 2018
- **Updated:** 17 Sep 2024
- **Also known as:** GHSA-5q8m-mqmx-pxp9

## What is CVE-2018-1274?

CVE-2018-1274 is a high-severity denial of service vulnerability in Spring Framework, published on 18 Apr 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Spring Data Commons, versions 1.13 to 1.13.10, 2.0 to 2.0.5, and older unsupported versions, contain a property path parser vulnerability caused by unlimited resource allocation. An unauthenticated remote malicious user (or attacker) can issue requests against Spring Data REST endpoints or endpoints using property path parsing which can cause a denial of service (CPU and memory consumption).

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling)

## Which versions are affected by CVE-2018-1274?

4 open source packages ship an affected version, including org.springframework.data:spring-data-commons. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.springframework.data:spring-data-commons` | Maven | All versions | 1.13.11 |
| `org.springframework.data:spring-data-commons` | Maven | All versions | 1.13.11 |
| `org.springframework.data:spring-data-commons` | Maven | From 2.0.0 | 2.0.6 |
| `org.springframework.data:spring-data-commons` | Maven | From 2.0.0 | 2.0.6 |

Products: Broadcom Spring Data Commons, Pivotal Software Spring Data Rest, Vmware Spring Data Rest.

## How do I fix CVE-2018-1274?

Upgrade org.springframework.data:spring-data-commons to a fixed version for your release line: 1.13.11 or 2.0.6.

## Is CVE-2018-1274 being exploited?

There is no known exploitation of CVE-2018-1274 in the wild and no public exploit code.

## Other vulnerabilities in Spring Framework

- [CVE-2026-41695](https://insights.sbomify.com/CVE-2026-41695/): Denial of Service in Spring Data Commons Property Path Resolution (high 7.5)
- [CVE-2026-41716](https://insights.sbomify.com/CVE-2026-41716/): Spring Data web support unbounded negative-result cache keyed on attacker-supplied property names (high 7.5)
- [CVE-2018-1259](https://insights.sbomify.com/CVE-2018-1259/): Spring Data Commons, used in combination with XMLBeam, contains a property binder vulnerability caused by improper restriction of XML external entity references (high 7.5)
- [CVE-2026-41711](https://insights.sbomify.com/CVE-2026-41711/): Potential Denial of Service through crafted Sort Parameters (medium 5.9)
- [CVE-2026-41721](https://insights.sbomify.com/CVE-2026-41721/): Spring Data Commons Denial of Service via Data Binding (medium 5.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-1274 and fix it if it is affected.

What it is: CVE-2018-1274 is a high-severity denial of service vulnerability in Spring Framework, published on 18 Apr 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-1274 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.springframework.data:spring-data-commons (Maven): affected all versions; fixed in 1.13.11
- org.springframework.data:spring-data-commons (Maven): affected all versions; fixed in 1.13.11
- org.springframework.data:spring-data-commons (Maven): affected from 2.0.0; fixed in 2.0.6
- org.springframework.data:spring-data-commons (Maven): affected from 2.0.0; fixed in 2.0.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-1274/ (Markdown: https://insights.sbomify.com/CVE-2018-1274/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-1274
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-1274
- OSV: https://osv.dev/vulnerability/CVE-2018-1274

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-1274/
Summaries are generated and may contain mistakes; the official description above is the record.
