# CVE-2018-1275: Spring Framework has Improperly Implemented Security Check for Standard

> Attackers can achieve remote code execution by sending crafted messages to STOMP over WebSocket endpoints in Spring Framework applications using the spring-messaging module.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 Apr 2018
- **Updated:** 17 Sep 2024
- **Also known as:** GHSA-3rmv-2pg5-xvqj

## What is CVE-2018-1275?

CVE-2018-1275 is a critical code injection vulnerability in Oracle Application Testing Suite, published on 11 Apr 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Spring Framework, versions 5.0 prior to 5.0.5 and versions 4.3 prior to 4.3.16 and older unsupported versions, allow applications to expose STOMP over WebSocket endpoints with a simple, in-memory STOMP broker through the spring-messaging module. A malicious user (or attacker) can craft a message to the broker that can lead to a remote code execution attack. This CVE addresses the partial fix for CVE-2018-1270 in the 4.3.x branch of the Spring Framework.

Weakness: CWE-358 (Improperly Implemented Security Check for Standard), CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2018-1275?

4 open source packages ship an affected version, including org.springframework:spring-messaging. It affects 19 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.springframework:spring-messaging` | Maven | All versions | 4.3.16.RELEASE |
| `org.springframework:spring-messaging` | Maven | All versions | 4.3.16.RELEASE |
| `org.springframework:spring-messaging` | Maven | From 5.0.0.RELEASE | 5.0.5.RELEASE |
| `org.springframework:spring-messaging` | Maven | From 5.0.0.RELEASE | 5.0.5.RELEASE |

Products: Oracle Application Testing Suite, Oracle Big Data Discovery, Oracle Communications Converged Application Server, Oracle Communications Diameter Signaling Router, Oracle Communications Performance Intelligence Center, Oracle Communications Services Gatekeeper, Oracle Goldengate for Big Data, Oracle Health Sciences Information Manager, Oracle Healthcare Master Person Index, Oracle Insurance Calculation Engine, Oracle Insurance Rules Palette, Oracle Primavera Gateway, Oracle Retail Customer Insights, Oracle Retail Open Commerce Platform, Oracle Retail Order Broker, Oracle Retail Predictive Application Server, Oracle Service Architecture Leveraging Tuxedo, Oracle Tape Library Acsls, Vmware Spring Framework.

## How do I fix CVE-2018-1275?

Upgrade org.springframework:spring-messaging to a fixed version for your release line: 4.3.16.RELEASE or 5.0.5.RELEASE.

## Is CVE-2018-1275 being exploited?

There is no known exploitation of CVE-2018-1275 in the wild and no public exploit code.

## Other vulnerabilities in Oracle Application Testing Suite

- [CVE-2026-35290](https://insights.sbomify.com/CVE-2026-35290/): Auth bypass in Oracle Application Testing Suite (critical 9.8)
- [CVE-2026-46876](https://insights.sbomify.com/CVE-2026-46876/): Auth bypass in Oracle Application Testing Suite (critical 9.8)
- [CVE-2026-46924](https://insights.sbomify.com/CVE-2026-46924/): Auth bypass in Oracle Application Testing Suite (critical 9.8)
- [CVE-2019-2904](https://insights.sbomify.com/CVE-2019-2904/): Auth bypass in Enterprise Repository (critical 9.8)
- [CVE-2026-70862](https://insights.sbomify.com/CVE-2026-70862/): Missing authorization in Oracle Application Testing Suite (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-1275 and fix it if it is affected.

What it is: CVE-2018-1275 is a critical code injection vulnerability in Oracle Application Testing Suite, published on 11 Apr 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-1275 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.springframework:spring-messaging (Maven): affected all versions; fixed in 4.3.16.RELEASE
- org.springframework:spring-messaging (Maven): affected all versions; fixed in 4.3.16.RELEASE
- org.springframework:spring-messaging (Maven): affected from 5.0.0.RELEASE; fixed in 5.0.5.RELEASE
- org.springframework:spring-messaging (Maven): affected from 5.0.0.RELEASE; fixed in 5.0.5.RELEASE

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-1275/ (Markdown: https://insights.sbomify.com/CVE-2018-1275/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-1275
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-1275
- OSV: https://osv.dev/vulnerability/CVE-2018-1275

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-1275/
Summaries are generated and may contain mistakes; the official description above is the record.
