# CVE-2018-1282: SQL Injection in hive-jdbc

> Attackers can bypass JDBC argument escaping in Apache Hive to execute arbitrary SQL commands, potentially reading or modifying data.

- **Severity:** Critical 9.1 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 5 Apr 2018
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-jf2m-435m-mxw8

## What is CVE-2018-1282?

CVE-2018-1282 is a critical SQL injection vulnerability in Apache Hive, published on 5 Apr 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

This vulnerability in Apache Hive JDBC driver 0.7.1 to 2.3.2 allows carefully crafted arguments to be used to bypass the argument escaping/cleanup that JDBC driver does in PreparedStatement implementation.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2018-1282?

2 open source packages ship an affected version, including org.apache.hive:hive-jdbc. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.hive:hive-jdbc` | Maven | From 0.7.1 | 2.3.3 |
| `org.apache.hive:hive-jdbc` | Maven | From 0.7.1 | 2.3.3 |

Products: Apache Hive.

## How do I fix CVE-2018-1282?

Upgrade org.apache.hive:hive-jdbc to 2.3.3 or later.

## Is CVE-2018-1282 being exploited?

There is no known exploitation of CVE-2018-1282 in the wild and no public exploit code.

## Other vulnerabilities in Apache Hive

- [CVE-2026-49845](https://insights.sbomify.com/CVE-2026-49845/): Apache Hive: SQL Injection vulnerability in HiveMetaStore partition-name direct-SQL paths (critical 9.8)
- [CVE-2018-21234](https://insights.sbomify.com/CVE-2018-21234/): Deserialization of Untrusted Data in Jodd (critical 9.8)
- [CVE-2026-55976](https://insights.sbomify.com/CVE-2026-55976/): Apache Hive: SSRF vulnerability in Hive Avro Serde due to Insufficient input validation on avro.schema.url (critical 9.1)
- [CVE-2022-41137](https://insights.sbomify.com/CVE-2022-41137/): Apache Hive: Deserialization of untrusted data when fetching partitions from the Metastore (high 8.3)
- [CVE-2015-7521](https://insights.sbomify.com/CVE-2015-7521/): High severity vulnerability that affects org.apache.hive:hive, org.apache.hive:hive-exec, and org.apache.hive:hive-service (high 8.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-1282 and fix it if it is affected.

What it is: CVE-2018-1282 is a critical SQL injection vulnerability in Apache Hive, published on 5 Apr 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-1282 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.hive:hive-jdbc (Maven): affected from 0.7.1; fixed in 2.3.3
- org.apache.hive:hive-jdbc (Maven): affected from 0.7.1; fixed in 2.3.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-1282/ (Markdown: https://insights.sbomify.com/CVE-2018-1282/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-1282
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-1282
- OSV: https://osv.dev/vulnerability/CVE-2018-1282

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-1282/
Summaries are generated and may contain mistakes; the official description above is the record.
