# CVE-2018-1284: Exposure of Sensitive Information to an Unauthorized Actor in Apache hive

> A malicious user can read arbitrary files on the HiveServer2 host via XPath UDFs when doAs is disabled, exposing sensitive data.

- **Severity:** Low 3.7 (`CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 5 Apr 2018
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-rxmr-c9jm-7mm8

## What is CVE-2018-1284?

CVE-2018-1284 is a low-severity vulnerability in Apache Hive, published on 5 Apr 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

In Apache Hive 0.6.0 to 2.3.2, malicious user might use any xpath UDFs (xpath/xpath_string/xpath_boolean/xpath_number/xpath_double/xpath_float/xpath_long/xpath_int/xpath_short) to expose the content of a file on the machine running HiveServer2 owned by HiveServer2 user (usually hive) if hive.server2.enable.doAs=false.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2018-1284?

6 open source packages ship an affected version, including org.apache.hive:hive, org.apache.hive:hive-exec and org.apache.hive:hive-service. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.hive:hive` | Maven | From 0.6.0 | 2.3.3 |
| `org.apache.hive:hive` | Maven | From 0.6.0 | 2.3.3 |
| `org.apache.hive:hive-exec` | Maven | From 0.6.0 | 2.3.3 |
| `org.apache.hive:hive-exec` | Maven | From 0.6.0 | 2.3.3 |
| `org.apache.hive:hive-service` | Maven | From 0.6.0 | 2.3.3 |
| `org.apache.hive:hive-service` | Maven | From 0.6.0 | 2.3.3 |

Products: Apache Hive.

## How do I fix CVE-2018-1284?

Upgrade org.apache.hive:hive to 2.3.3 or later.

## Is CVE-2018-1284 being exploited?

There is no known exploitation of CVE-2018-1284 in the wild and no public exploit code.

## Other vulnerabilities in Apache Hive

- [CVE-2026-49845](https://insights.sbomify.com/CVE-2026-49845/): Apache Hive: SQL Injection vulnerability in HiveMetaStore partition-name direct-SQL paths (critical 9.8)
- [CVE-2018-21234](https://insights.sbomify.com/CVE-2018-21234/): Deserialization of Untrusted Data in Jodd (critical 9.8)
- [CVE-2026-55976](https://insights.sbomify.com/CVE-2026-55976/): Apache Hive: SSRF vulnerability in Hive Avro Serde due to Insufficient input validation on avro.schema.url (critical 9.1)
- [CVE-2018-1282](https://insights.sbomify.com/CVE-2018-1282/): SQL Injection in hive-jdbc (critical 9.1)
- [CVE-2022-41137](https://insights.sbomify.com/CVE-2022-41137/): Apache Hive: Deserialization of untrusted data when fetching partitions from the Metastore (high 8.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-1284 and fix it if it is affected.

What it is: CVE-2018-1284 is a low-severity vulnerability in Apache Hive, published on 5 Apr 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-1284 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.hive:hive (Maven): affected from 0.6.0; fixed in 2.3.3
- org.apache.hive:hive (Maven): affected from 0.6.0; fixed in 2.3.3
- org.apache.hive:hive-exec (Maven): affected from 0.6.0; fixed in 2.3.3
- org.apache.hive:hive-exec (Maven): affected from 0.6.0; fixed in 2.3.3
- org.apache.hive:hive-service (Maven): affected from 0.6.0; fixed in 2.3.3
- org.apache.hive:hive-service (Maven): affected from 0.6.0; fixed in 2.3.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-1284/ (Markdown: https://insights.sbomify.com/CVE-2018-1284/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-1284
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-1284
- OSV: https://osv.dev/vulnerability/CVE-2018-1284

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-1284/
Summaries are generated and may contain mistakes; the official description above is the record.
