# CVE-2018-1286: Apache OpenMeetings may allow authenticated attacker to deny service for privileged users

> An authenticated attacker can modify privileged user accounts without password verification, causing denial of service for those users.

- **Severity:** Medium 6.5 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 Feb 2018
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-cv9j-7q4x-v2g2

## What is CVE-2018-1286?

CVE-2018-1286 is a medium-severity missing authorization vulnerability in Apache OpenMeetings, published on 28 Feb 2018. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

In Apache OpenMeetings 3.0.0 - 4.0.1, CRUD operations on privileged users are not password protected allowing an authenticated attacker to deny service for privileged users.

Weakness: CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2018-1286?

2 open source packages ship an affected version, including org.apache.openmeetings:openmeetings-parent. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.openmeetings:openmeetings-parent` | Maven | From 3.0.0 | 4.0.2 |
| `org.apache.openmeetings:openmeetings-parent` | Maven | From 3.0.0 | 4.0.2 |

Products: Apache Openmeetings.

## How do I fix CVE-2018-1286?

Upgrade org.apache.openmeetings:openmeetings-parent to 4.0.2 or later.

## Is CVE-2018-1286 being exploited?

There is no known exploitation of CVE-2018-1286 in the wild and no public exploit code.

## Other vulnerabilities in Apache OpenMeetings

- [CVE-2017-7664](https://insights.sbomify.com/CVE-2017-7664/): Apache OpenMeetings does not correctly validate uploaded XML documents (critical 10.0)
- [CVE-2024-54676](https://insights.sbomify.com/CVE-2024-54676/): Apache OpenMeetings: Deserialisation of untrusted data in cluster mode (critical 9.8)
- [CVE-2023-28326](https://insights.sbomify.com/CVE-2023-28326/): Apache OpenMeetings: allows user impersonation (critical 9.8)
- [CVE-2016-8736](https://insights.sbomify.com/CVE-2016-8736/): Apache OpenMeetings RCE (critical 9.8)
- [CVE-2017-7673](https://insights.sbomify.com/CVE-2017-7673/): Apache OpenMeetings has Inadequate Encryption Strength (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-1286 and fix it if it is affected.

What it is: CVE-2018-1286 is a medium-severity missing authorization vulnerability in Apache OpenMeetings, published on 28 Feb 2018. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-1286 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.openmeetings:openmeetings-parent (Maven): affected from 3.0.0; fixed in 4.0.2
- org.apache.openmeetings:openmeetings-parent (Maven): affected from 3.0.0; fixed in 4.0.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-1286/ (Markdown: https://insights.sbomify.com/CVE-2018-1286/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-1286
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-1286
- OSV: https://osv.dev/vulnerability/CVE-2018-1286

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-1286/
Summaries are generated and may contain mistakes; the official description above is the record.
