{"answers":{"affected":"It affects 3 products.","exploited":"There is no known exploitation of CVE-2018-12882 in the wild and no public exploit code.","fix":"Apply the vendor's patch.","what":"CVE-2018-12882 is a critical use after free vulnerability in Canonical Ubuntu Linux, published on 26 Jun 2018. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2018-12882 and fix it if it is affected.\n\nWhat it is: CVE-2018-12882 is a critical use after free vulnerability in Canonical Ubuntu Linux, published on 26 Jun 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2018-12882 in the wild and no public exploit code.\n\nAffected product: Canonical Ubuntu Linux. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2018-12882/ (Markdown: https://insights.sbomify.com/CVE-2018-12882/index.md)","id":"CVE-2018-12882","markdown":"https://insights.sbomify.com/CVE-2018-12882/index.md","name":"CVE-2018-12882","record":{"aliases":["GHSA-p666-3cc6-g2c6","SUSE-SU-2018:1886-1","SUSE-SU-2018:1936-1","SUSE-SU-2018:1936-2","UBUNTU-CVE-2018-12882","USN-3702-1","USN-3702-2"],"analysis":{"component_type":"library","fix_type":"patch","impacts":["code_execution","denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"PHP exif extension","requires_auth":"none","summary":"Attackers can trigger a use-after-free in PHP's exif extension via crafted image files, potentially leading to code execution or crashes.","user_interaction":"not_required","vuln_class":"use_after_free"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"ubuntu_linux","vendor":"canonical"},{"product":"storage_automation_store","vendor":"netapp"},{"product":"php","vendor":"php"}],"cvss":{"score":9.8,"severity":"critical","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-416","name":"Use After Free"}],"description":"exif_read_from_impl in ext/exif/exif.c in PHP 7.2.x through 7.2.7 allows attackers to trigger a use-after-free (in exif_read_from_file) because it closes a stream that it is not responsible for closing. The vulnerable code is reachable through the PHP exif_read_data function.","ecosystems":["SUSE:Linux Enterprise Module for Web and Scripting 12","SUSE:Linux Enterprise Module for Web and Scripting 15","SUSE:Linux Enterprise Software Development Kit 12 SP3"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Use after free in n/a","id":"CVE-2018-12882","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":"canonical:ubuntu_linux","products":["canonical:ubuntu_linux","netapp:storage_automation_store","php:php"],"type":"use_after_free","year":"2018"},"n_packages":4,"n_references":5,"next":{"headline":"Privilege escalation in n/a","id":"CVE-2018-12884"},"packages":[{"ecosystem":"SUSE:Linux Enterprise Module for Web and Scripting 12","fixed":["7.0.7-50.41.1"],"introduced":["0"],"last_affected":[],"package":"php7","purl":"pkg:rpm/suse/php7\u0026distro=SUSE%20Linux%20Enterprise%20Module%20for%20Web%20and%20Scripting%2012","source":"SUSE-SU-2018:1886-1"},{"ecosystem":"SUSE:Linux Enterprise Module for Web and Scripting 15","fixed":["7.2.5-4.3.1"],"introduced":["0"],"last_affected":[],"package":"php7","purl":"pkg:rpm/suse/php7\u0026distro=SUSE%20Linux%20Enterprise%20Module%20for%20Web%20and%20Scripting%2015","source":"SUSE-SU-2018:1936-1"},{"ecosystem":"SUSE:Linux Enterprise Module for Web and Scripting 15","fixed":["7.2.5-4.3.1"],"introduced":["0"],"last_affected":[],"package":"php7","purl":"pkg:rpm/suse/php7\u0026distro=SUSE%20Linux%20Enterprise%20Module%20for%20Web%20and%20Scripting%2015","source":"SUSE-SU-2018:1936-2"},{"ecosystem":"SUSE:Linux Enterprise Software Development Kit 12 SP3","fixed":["7.0.7-50.41.1"],"introduced":["0"],"last_affected":[],"package":"php7","purl":"pkg:rpm/suse/php7\u0026distro=SUSE%20Linux%20Enterprise%20Software%20Development%20Kit%2012%20SP3","source":"SUSE-SU-2018:1886-1"}],"prev":{"headline":"Integer overflow in Adobe Acrobat and Reader","id":"CVE-2018-12881"},"products":["n/a"],"published":"2018-06-26","related":[{"cvss_score":9.8,"headline":"SaltStack Salt Authentication Bypass","id":"CVE-2020-11651","kev_date_added":"2021-11-03","published":"2020-04-30"},{"cvss_score":9.8,"headline":"OpenSMTPD Remote Code Execution","id":"CVE-2020-7247","kev_date_added":"2022-03-25","published":"2020-01-29"},{"cvss_score":9.8,"headline":"Exim Out-of-bounds Write","id":"CVE-2019-16928","kev_date_added":"2022-03-03","published":"2019-09-27"},{"cvss_score":9.8,"headline":"Exim Buffer Overflow","id":"CVE-2018-6789","kev_date_added":"2021-11-03","published":"2018-02-08"},{"cvss_score":9.8,"headline":"Oracle Java SE and Java SE Embedded Remote Code Execution","id":"CVE-2015-2590","kev_date_added":"2022-03-03","published":"2015-07-16"},{"cvss_score":9.8,"headline":"Oracle JRE Remote Code Execution","id":"CVE-2013-0422","kev_date_added":"2022-05-25","published":"2013-01-10"},{"cvss_score":9.8,"headline":"Oracle Java SE Runtime Environment (JRE) Arbitrary Code Execution","id":"CVE-2011-3544","kev_date_added":"2022-03-03","published":"2011-10-19"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"SUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"Attackers can trigger a use-after-free in PHP's exif extension via crafted image files, potentially leading to code execution or crashes.","url":"https://insights.sbomify.com/CVE-2018-12882/"}