{"answers":{"affected":"2 open source packages ship an affected version, including org.apache.commons:commons-email. It affects 1 product.","exploited":"There is no known exploitation of CVE-2018-1294 in the wild and no public exploit code.","fix":"Upgrade org.apache.commons:commons-email to 1.5 or later.","what":"CVE-2018-1294 is a high-severity vulnerability in Apache Commons Email, published on 20 Mar 2018. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2018-1294 and fix it if it is affected.\n\nWhat it is: CVE-2018-1294 is a high-severity vulnerability in Apache Commons Email, published on 20 Mar 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2018-1294 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.apache.commons:commons-email (Maven): affected all versions; fixed in 1.5\n- org.apache.commons:commons-email (Maven): affected all versions; fixed in 1.5\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2018-1294/ (Markdown: https://insights.sbomify.com/CVE-2018-1294/index.md)","id":"CVE-2018-1294","markdown":"https://insights.sbomify.com/CVE-2018-1294/index.md","name":"CVE-2018-1294","record":{"aliases":["GHSA-v7cm-w955-pj6g","MGASA-2018-0136"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"Java email library","requires_auth":"none","summary":"Attackers can manipulate email details like recipients and content by injecting line breaks into the bounce address field in Apache Commons Email.","user_interaction":"not_required","vuln_class":"other"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"commons_email","vendor":"apache"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N","version":"3.0"},"cwes":[{"id":"CWE-20","name":"Improper Input Validation"}],"description":"If a user of Apache Commons Email (typically an application programmer) passes unvalidated input as the so-called \"Bounce Address\", and that input contains line-breaks, then the email details (recipients, contents, etc.) might be manipulated. Mitigation: Users should upgrade to Commons-Email 1.5. You can mitigate this vulnerability for older versions of Commons Email by stripping line-breaks from data, that will be passed to Email.setBounceAddress(String).","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Improper Input Validation Apache Commons Email","id":"CVE-2018-1294","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"other","year":"2018"},"n_packages":2,"n_references":1,"next":{"headline":"Apache serialization mechanism does not have a list of classes allowed for serialization/deserialization","id":"CVE-2018-1295"},"packages":[{"ecosystem":"Maven","fixed":["1.5"],"introduced":["0"],"last_affected":[],"package":"org.apache.commons:commons-email","purl":null,"source":"GHSA-v7cm-w955-pj6g"},{"ecosystem":"Maven","fixed":["1.5"],"introduced":["0"],"last_affected":[],"package":"org.apache.commons:commons-email","purl":"pkg:maven/org.apache.commons/commons-email","source":"GHSA-v7cm-w955-pj6g"}],"prev":{"headline":"DO NOT USE THIS CANDIDATE NUMBER.","id":"CVE-2018-1293"},"products":["Apache Commons Email"],"published":"2018-03-20","related":[{"cvss_score":7.5,"headline":"Improper Input Validation in Apache Commons Email","id":"CVE-2017-9801","kev_date_added":null,"published":"2017-08-07"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-16","vendors":["Apache Software Foundation"]},"summary":"Attackers can manipulate email details like recipients and content by injecting line breaks into the bounce address field in Apache Commons Email.","url":"https://insights.sbomify.com/CVE-2018-1294/"}