# CVE-2018-1294: Improper Input Validation Apache Commons Email

> Attackers can manipulate email details like recipients and content by injecting line breaks into the bounce address field in Apache Commons Email.

- **Severity:** High 7.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Mar 2018
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-v7cm-w955-pj6g, MGASA-2018-0136

## What is CVE-2018-1294?

CVE-2018-1294 is a high-severity vulnerability in Apache Commons Email, published on 20 Mar 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

If a user of Apache Commons Email (typically an application programmer) passes unvalidated input as the so-called "Bounce Address", and that input contains line-breaks, then the email details (recipients, contents, etc.) might be manipulated. Mitigation: Users should upgrade to Commons-Email 1.5. You can mitigate this vulnerability for older versions of Commons Email by stripping line-breaks from data, that will be passed to Email.setBounceAddress(String).

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2018-1294?

2 open source packages ship an affected version, including org.apache.commons:commons-email. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.commons:commons-email` | Maven | All versions | 1.5 |
| `org.apache.commons:commons-email` | Maven | All versions | 1.5 |

Products: Apache Commons Email.

## How do I fix CVE-2018-1294?

Upgrade org.apache.commons:commons-email to 1.5 or later.

## Is CVE-2018-1294 being exploited?

There is no known exploitation of CVE-2018-1294 in the wild and no public exploit code.

## Other vulnerabilities in Apache Commons Email

- [CVE-2017-9801](https://insights.sbomify.com/CVE-2017-9801/): Improper Input Validation in Apache Commons Email (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-1294 and fix it if it is affected.

What it is: CVE-2018-1294 is a high-severity vulnerability in Apache Commons Email, published on 20 Mar 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-1294 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.commons:commons-email (Maven): affected all versions; fixed in 1.5
- org.apache.commons:commons-email (Maven): affected all versions; fixed in 1.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-1294/ (Markdown: https://insights.sbomify.com/CVE-2018-1294/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-1294
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-1294
- OSV: https://osv.dev/vulnerability/CVE-2018-1294

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-1294/
Summaries are generated and may contain mistakes; the official description above is the record.
