{"answers":{"affected":"2 open source packages ship an affected version, including org.apache.qpid:apache-qpid-broker-j. It affects 1 product.","exploited":"There is no known exploitation of CVE-2018-1298 in the wild and no public exploit code.","fix":"Upgrade org.apache.qpid:apache-qpid-broker-j to 7.0.1 or later.","what":"CVE-2018-1298 is a medium-severity denial of service vulnerability in Apache Qpid Broker-J, published on 9 Feb 2018. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2018-1298 and fix it if it is affected.\n\nWhat it is: CVE-2018-1298 is a medium-severity denial of service vulnerability in Apache Qpid Broker-J, published on 9 Feb 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2018-1298 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.apache.qpid:apache-qpid-broker-j (Maven): affected from 7.0.0; fixed in 7.0.1\n- org.apache.qpid:apache-qpid-broker-j (Maven): affected from 7.0.0; fixed in 7.0.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2018-1298/ (Markdown: https://insights.sbomify.com/CVE-2018-1298/index.md)","id":"CVE-2018-1298","markdown":"https://insights.sbomify.com/CVE-2018-1298/index.md","name":"CVE-2018-1298","record":{"aliases":["GHSA-6w3v-66mj-2qm6"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":true,"product_category":"Apache Qpid Broker","requires_auth":"none","summary":"Unauthenticated attackers can crash the Apache Qpid Broker-J instance via AMQP connections if specific SASL authentication providers are configured.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"qpid_broker-j","vendor":"apache"}],"cvss":{"score":5.9,"severity":"medium","source":"nvd","vector":"CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.0"},"cwes":[{"id":"CWE-20","name":"Improper Input Validation"}],"description":"A Denial of Service vulnerability was found in Apache Qpid Broker-J 7.0.0 in functionality for authentication of connections for AMQP protocols 0-8, 0-9, 0-91 and 0-10 when PLAIN or XOAUTH2 SASL mechanism is used. The vulnerability allows unauthenticated attacker to crash the broker instance. AMQP 1.0 and HTTP connections are not affected. An authentication of incoming AMQP connections in Apache Qpid Broker-J is performed by special entities called \"Authentication Providers\". Each Authentication Provider can support several SASL mechanisms which are offered to the connecting clients as part of SASL negotiation process. The client chooses the most appropriate SASL mechanism for authentication. Authentication Providers of following types supports PLAIN SASL mechanism: Plain, PlainPasswordFile, SimpleLDAP, Base64MD5PasswordFile, MD5, SCRAM-SHA-256, SCRAM-SHA-1. XOAUTH2 SASL mechanism is supported by Authentication Providers of type OAuth2. If an AMQP port is configured with any of these Authentication Providers, the Broker may be vulnerable.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Moderate severity vulnerability that affects org.apache.qpid:apache-qpid-broker-j","id":"CVE-2018-1298","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"denial_of_service","year":"2018"},"n_packages":2,"n_references":1,"next":{"headline":"Path traversal in Apache Allura","id":"CVE-2018-1299"},"packages":[{"ecosystem":"Maven","fixed":["7.0.1"],"introduced":["7.0.0"],"last_affected":[],"package":"org.apache.qpid:apache-qpid-broker-j","purl":null,"source":"GHSA-6w3v-66mj-2qm6"},{"ecosystem":"Maven","fixed":["7.0.1"],"introduced":["7.0.0"],"last_affected":[],"package":"org.apache.qpid:apache-qpid-broker-j","purl":"pkg:maven/org.apache.qpid/apache-qpid-broker-j","source":"GHSA-6w3v-66mj-2qm6"}],"prev":{"headline":"Missing certificate validation in Apache JMeter","id":"CVE-2018-1297"},"products":["Apache Qpid Broker-J"],"published":"2018-02-09","related":[{"cvss_score":9.8,"headline":"Apache Qpid Broker-J: Missing HTTP-session renewal after successful authentication","id":"CVE-2026-92609","kev_date_added":null,"published":"2026-09-25"},{"cvss_score":9.8,"headline":"Apache Qpid Broker vulnerable to authentication port spoofing","id":"CVE-2017-15702","kev_date_added":null,"published":"2017-12-01"},{"cvss_score":9.1,"headline":"AMQP 0-8, 0-9, 0-91, and 0-10 connection handling in Apache Qpid Java before 6.0.3 might allow remote attackers to bypass authentication","id":"CVE-2016-4432","kev_date_added":null,"published":"2016-06-01"},{"cvss_score":7.5,"headline":"Denial of service in Apache Qpid Broker-J","id":"CVE-2026-92550","kev_date_added":null,"published":"2026-09-25"},{"cvss_score":7.5,"headline":"Denial of service in Apache Qpid Broker-J","id":"CVE-2026-92560","kev_date_added":null,"published":"2026-09-25"},{"cvss_score":7.5,"headline":"Denial of service in Apache Qpid Broker-J","id":"CVE-2026-92564","kev_date_added":null,"published":"2026-09-25"},{"cvss_score":7.5,"headline":"Apache Qpid Broker-J: Incomplete property conversion handling from AMQP 1.0 to AMQP 0-10","id":"CVE-2026-92608","kev_date_added":null,"published":"2026-09-25"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-16","vendors":["Apache Software Foundation"]},"summary":"Unauthenticated attackers can crash the Apache Qpid Broker-J instance via AMQP connections if specific SASL authentication providers are configured.","url":"https://insights.sbomify.com/CVE-2018-1298/"}