{"answers":{"affected":"2 open source packages ship an affected version, including org.apache.juddi:juddi-client. It affects 1 product.","exploited":"There is no known exploitation of CVE-2018-1307 in the wild and no public exploit code.","fix":"Upgrade org.apache.juddi:juddi-client to 3.3.5 or later.","what":"CVE-2018-1307 is a high-severity vulnerability in Apache jUDDI, published on 9 Feb 2018. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2018-1307 and fix it if it is affected.\n\nWhat it is: CVE-2018-1307 is a high-severity vulnerability in Apache jUDDI, published on 9 Feb 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2018-1307 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.apache.juddi:juddi-client (Maven): affected from 3.2; fixed in 3.3.5\n- org.apache.juddi:juddi-client (Maven): affected from 3.2; fixed in 3.3.5\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2018-1307/ (Markdown: https://insights.sbomify.com/CVE-2018-1307/index.md)","id":"CVE-2018-1307","markdown":"https://insights.sbomify.com/CVE-2018-1307/index.md","name":"CVE-2018-1307","record":{"aliases":["GHSA-p99p-726h-c8v5"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read","denial_of_service"],"network_reachable":"yes","non_default_config":true,"product_category":"Java UDDI library","requires_auth":"none","summary":"Attackers can exploit XML parsing flaws in Apache jUDDI to read sensitive files or cause denial of service when using specific WADL/WSDL conversion classes.","user_interaction":"not_required","vuln_class":"xxe"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"juddi","vendor":"apache"}],"cvss":{"score":8.1,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-611","name":"Improper Restriction of XML External Entity Reference"}],"description":"In Apache jUDDI 3.2 through 3.3.4, if using the WADL2Java or WSDL2Java classes, which parse a local or remote XML document and then mediates the data structures into UDDI data structures, there are little protections present against entity expansion and DTD type of attacks. Mitigation is to use 3.3.5.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Apache juddi-client vulnerable to XML External Entity (XXE)","id":"CVE-2018-1307","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"xxe","year":"2018"},"n_packages":2,"n_references":2,"next":{"headline":"There is a XML external entity expansion (XXE) vulnerability in Apache Solr","id":"CVE-2018-1308"},"packages":[{"ecosystem":"Maven","fixed":["3.3.5"],"introduced":["3.2"],"last_affected":[],"package":"org.apache.juddi:juddi-client","purl":null,"source":"GHSA-p99p-726h-c8v5"},{"ecosystem":"Maven","fixed":["3.3.5"],"introduced":["3.2"],"last_affected":[],"package":"org.apache.juddi:juddi-client","purl":"pkg:maven/org.apache.juddi/juddi-client","source":"GHSA-p99p-726h-c8v5"}],"prev":{"headline":"Exposure of Sensitive Information in Apache Pluto","id":"CVE-2018-1306"},"products":["Apache jUDDI"],"published":"2018-02-09","related":[{"cvss_score":9.8,"headline":"Remote code execution via RMI","id":"CVE-2021-37578","kev_date_added":null,"published":"2021-07-29"},{"cvss_score":6.5,"headline":"Other in jUDDI","id":"CVE-2009-4267","kev_date_added":null,"published":"2018-02-19"},{"cvss_score":6.1,"headline":"Cross-site scripting in n/a","id":"CVE-2009-1198","kev_date_added":null,"published":"2017-10-30"},{"cvss_score":6.1,"headline":"Moderate severity vulnerability that affects org.apache.juddi:juddi-client","id":"CVE-2015-5241","kev_date_added":null,"published":"2017-05-19"},{"cvss_score":5.3,"headline":"Other in n/a","id":"CVE-2009-1197","kev_date_added":null,"published":"2017-10-30"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-16","vendors":["Apache Software Foundation"]},"summary":"Attackers can exploit XML parsing flaws in Apache jUDDI to read sensitive files or cause denial of service when using specific WADL/WSDL conversion classes.","url":"https://insights.sbomify.com/CVE-2018-1307/"}