# CVE-2018-1307: Apache juddi-client vulnerable to XML External Entity (XXE)

> Attackers can exploit XML parsing flaws in Apache jUDDI to read sensitive files or cause denial of service when using specific WADL/WSDL conversion classes.

- **Severity:** High 8.1 (`CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Feb 2018
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-p99p-726h-c8v5

## What is CVE-2018-1307?

CVE-2018-1307 is a high-severity vulnerability in Apache jUDDI, published on 9 Feb 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

In Apache jUDDI 3.2 through 3.3.4, if using the WADL2Java or WSDL2Java classes, which parse a local or remote XML document and then mediates the data structures into UDDI data structures, there are little protections present against entity expansion and DTD type of attacks. Mitigation is to use 3.3.5.

Weakness: CWE-611 (Improper Restriction of XML External Entity Reference)

## Which versions are affected by CVE-2018-1307?

2 open source packages ship an affected version, including org.apache.juddi:juddi-client. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.juddi:juddi-client` | Maven | From 3.2 | 3.3.5 |
| `org.apache.juddi:juddi-client` | Maven | From 3.2 | 3.3.5 |

Products: Apache Juddi.

## How do I fix CVE-2018-1307?

Upgrade org.apache.juddi:juddi-client to 3.3.5 or later.

## Is CVE-2018-1307 being exploited?

There is no known exploitation of CVE-2018-1307 in the wild and no public exploit code.

## Other vulnerabilities in Apache jUDDI

- [CVE-2021-37578](https://insights.sbomify.com/CVE-2021-37578/): Remote code execution via RMI (critical 9.8)
- [CVE-2009-4267](https://insights.sbomify.com/CVE-2009-4267/): Other in jUDDI (medium 6.5)
- [CVE-2009-1198](https://insights.sbomify.com/CVE-2009-1198/): Cross-site scripting in n/a (medium 6.1)
- [CVE-2015-5241](https://insights.sbomify.com/CVE-2015-5241/): Moderate severity vulnerability that affects org.apache.juddi:juddi-client (medium 6.1)
- [CVE-2009-1197](https://insights.sbomify.com/CVE-2009-1197/): Other in n/a (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-1307 and fix it if it is affected.

What it is: CVE-2018-1307 is a high-severity vulnerability in Apache jUDDI, published on 9 Feb 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-1307 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.juddi:juddi-client (Maven): affected from 3.2; fixed in 3.3.5
- org.apache.juddi:juddi-client (Maven): affected from 3.2; fixed in 3.3.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-1307/ (Markdown: https://insights.sbomify.com/CVE-2018-1307/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-1307
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-1307
- OSV: https://osv.dev/vulnerability/CVE-2018-1307

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-1307/
Summaries are generated and may contain mistakes; the official description above is the record.
