# CVE-2018-1308: There is a XML external entity expansion (XXE) vulnerability in Apache Solr

> Attackers can exploit an XML External Entity vulnerability in Apache Solr's DataImportHandler to read arbitrary local files or internal network resources.

- **Severity:** High 7.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Apr 2018
- **Updated:** 17 Sep 2024
- **Also known as:** DEBIAN-CVE-2018-1308, DLA-1360-1, DSA-4194-1, GHSA-3pph-2595-cgfh, UBUNTU-CVE-2018-1308

## What is CVE-2018-1308?

CVE-2018-1308 is a high-severity vulnerability in Debian Debian Linux, published on 9 Apr 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

This vulnerability in Apache Solr 1.2 to 6.6.2 and 7.0.0 to 7.2.1 relates to an XML external entity expansion (XXE) in the `&dataConfig=<inlinexml>` parameter of Solr's DataImportHandler. It can be used as XXE using file/ftp/http protocols in order to read arbitrary local files from the Solr server or the internal network.

Weakness: CWE-611 (Improper Restriction of XML External Entity Reference)

## Which versions are affected by CVE-2018-1308?

4 open source packages ship an affected version, including org.apache.solr:solr-core. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.solr:solr-core` | Maven | From 1.2 | 6.6.3 |
| `org.apache.solr:solr-core` | Maven | From 1.2 | 6.6.3 |
| `org.apache.solr:solr-core` | Maven | From 7.0.0 | 7.3.0 |
| `org.apache.solr:solr-core` | Maven | From 7.0.0 | 7.3.0 |

Products: Apache Solr, Debian Debian Linux.

## How do I fix CVE-2018-1308?

Upgrade org.apache.solr:solr-core to a fixed version for your release line: 6.6.3 or 7.3.0.

## Is CVE-2018-1308 being exploited?

There is no known exploitation of CVE-2018-1308 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2019-17558](https://insights.sbomify.com/CVE-2019-17558/): Apache Solr VelocityResponseWriter Plug-In Remote Code Execution (high 7.5, exploited in the wild)
- [CVE-2019-0193](https://insights.sbomify.com/CVE-2019-0193/): Apache Solr DataImportHandler Code Injection (high 7.2, exploited in the wild)
- [CVE-2024-45216](https://insights.sbomify.com/CVE-2024-45216/): Apache Solr: Authentication bypass possible using a fake URL Path ending (critical 9.8)
- [CVE-2021-44548](https://insights.sbomify.com/CVE-2021-44548/): Apache Solr information disclosure vulnerability through DataImportHandler (critical 9.8)
- [CVE-2021-27905](https://insights.sbomify.com/CVE-2021-27905/): SSRF vulnerability with the Replication handler (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-1308 and fix it if it is affected.

What it is: CVE-2018-1308 is a high-severity vulnerability in Debian Debian Linux, published on 9 Apr 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-1308 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.solr:solr-core (Maven): affected from 1.2; fixed in 6.6.3
- org.apache.solr:solr-core (Maven): affected from 1.2; fixed in 6.6.3
- org.apache.solr:solr-core (Maven): affected from 7.0.0; fixed in 7.3.0
- org.apache.solr:solr-core (Maven): affected from 7.0.0; fixed in 7.3.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-1308/ (Markdown: https://insights.sbomify.com/CVE-2018-1308/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-1308
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-1308
- OSV: https://osv.dev/vulnerability/CVE-2018-1308

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-1308/
Summaries are generated and may contain mistakes; the official description above is the record.
