{"answers":{"affected":"2 open source packages ship an affected version, including org.apache.derby:derby. It affects 2 products.","exploited":"There is no known exploitation of CVE-2018-1313 in the wild and no public exploit code.","fix":"Upgrade org.apache.derby:derby to 10.14.2.0 or later.","what":"CVE-2018-1313 is a medium-severity path traversal vulnerability in Oracle Weblogic Server, published on 7 May 2018. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2018-1313 and fix it if it is affected.\n\nWhat it is: CVE-2018-1313 is a medium-severity path traversal vulnerability in Oracle Weblogic Server, published on 7 May 2018. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2018-1313 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.apache.derby:derby (Maven): affected from 10.3.1.4; fixed in 10.14.2.0\n- org.apache.derby:derby (Maven): affected from 10.3.1.4; fixed in 10.14.2.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2018-1313/ (Markdown: https://insights.sbomify.com/CVE-2018-1313/index.md)","id":"CVE-2018-1313","markdown":"https://insights.sbomify.com/CVE-2018-1313/index.md","name":"CVE-2018-1313","record":{"aliases":["DEBIAN-CVE-2018-1313","GHSA-42xw-p62x-hwcf","OESA-2022-1780","UBUNTU-CVE-2018-1313"],"analysis":{"component_type":"database","fix_type":"configuration_change","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Apache Derby Network Server","requires_auth":"low_privilege","summary":"Attackers can force the Derby Network Server to load a malicious database, potentially executing code if the default permissive security policy is used.","user_interaction":"not_required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"derby","vendor":"apache"},{"product":"weblogic_server","vendor":"oracle"}],"cvss":{"score":5.3,"severity":"medium","source":"nvd","vector":"CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:N/I:H/A:N","version":"3.1"},"cwes":[],"description":"In Apache Derby 10.3.1.4 to 10.14.1.0, a specially-crafted network packet can be used to request the Derby Network Server to boot a database whose location and contents are under the user's control. If the Derby Network Server is not running with a Java Security Manager policy file, the attack is successful. If the server is using a policy file, the policy file must permit the database location to be read for the attack to work. The default Derby Network Server policy file distributed with the affected releases includes a permissive policy as the default Network Server policy, which allows the attack to work.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":"2018-11-19","github_poc":1,"max_poc_stars":0,"metasploit":0,"nuclei":0,"refs":[{"date":"2018-11-19T12:38:21Z","kind":"github_poc","ref":"https://github.com/tafamace/CVE-2018-1313","stars":0,"title":null}],"tier":"poc_unverified"},"has_fix":true,"headline":"Improper Access Control in Apache Derby","id":"CVE-2018-1313","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":"oracle:weblogic_server","products":["oracle:weblogic_server"],"type":"path_traversal","year":"2018"},"n_packages":2,"n_references":9,"next":{"headline":"Moderate severity vulnerability that affects org.apache.hive:hive-jdbc","id":"CVE-2018-1314"},"packages":[{"ecosystem":"Maven","fixed":["10.14.2.0"],"introduced":["10.3.1.4"],"last_affected":[],"package":"org.apache.derby:derby","purl":null,"source":"GHSA-42xw-p62x-hwcf"},{"ecosystem":"Maven","fixed":["10.14.2.0"],"introduced":["10.3.1.4"],"last_affected":[],"package":"org.apache.derby:derby","purl":"pkg:maven/org.apache.derby/derby","source":"GHSA-42xw-p62x-hwcf"}],"prev":{"headline":"Security feature bypass in Apache HTTP Server","id":"CVE-2018-1312"},"products":["Apache Derby"],"published":"2018-05-07","related":[{"cvss_score":9.8,"headline":"Apache Derby: LDAP injection vulnerability in authenticator","id":"CVE-2022-46337","kev_date_added":null,"published":"2023-11-20"},{"cvss_score":9.1,"headline":"Improper Restriction of XML External Entity Reference in Apace Derby","id":"CVE-2015-1832","kev_date_added":null,"published":"2016-10-03"},{"cvss_score":7.5,"headline":"Improper Access Control in Apache Derby","id":"CVE-2010-2232","kev_date_added":null,"published":"2017-10-23"},{"cvss_score":5,"headline":"Apache Derby exposes user and password attributes","id":"CVE-2005-4849","kev_date_added":null,"published":"2007-07-05"},{"cvss_score":4,"headline":"Missing authorization in n/a","id":"CVE-2006-7216","kev_date_added":null,"published":"2007-07-05"},{"cvss_score":4,"headline":"Apache Derby SQL Injection","id":"CVE-2006-7217","kev_date_added":null,"published":"2007-07-05"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-16","vendors":["Apache Software Foundation"]},"summary":"Attackers can force the Derby Network Server to load a malicious database, potentially executing code if the default permissive security policy is used.","url":"https://insights.sbomify.com/CVE-2018-1313/"}