# CVE-2018-1313: Improper Access Control in Apache Derby

> Attackers can force the Derby Network Server to load a malicious database, potentially executing code if the default permissive security policy is used.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 May 2018
- **Updated:** 16 Sep 2024
- **Also known as:** DEBIAN-CVE-2018-1313, GHSA-42xw-p62x-hwcf, OESA-2022-1780, UBUNTU-CVE-2018-1313

## What is CVE-2018-1313?

CVE-2018-1313 is a medium-severity path traversal vulnerability in Oracle Weblogic Server, published on 7 May 2018. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

In Apache Derby 10.3.1.4 to 10.14.1.0, a specially-crafted network packet can be used to request the Derby Network Server to boot a database whose location and contents are under the user's control. If the Derby Network Server is not running with a Java Security Manager policy file, the attack is successful. If the server is using a policy file, the policy file must permit the database location to be read for the attack to work. The default Derby Network Server policy file distributed with the affected releases includes a permissive policy as the default Network Server policy, which allows the attack to work.

## Which versions are affected by CVE-2018-1313?

2 open source packages ship an affected version, including org.apache.derby:derby. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.derby:derby` | Maven | From 10.3.1.4 | 10.14.2.0 |
| `org.apache.derby:derby` | Maven | From 10.3.1.4 | 10.14.2.0 |

Products: Apache Derby, Oracle Weblogic Server.

## How do I fix CVE-2018-1313?

Upgrade org.apache.derby:derby to 10.14.2.0 or later.

## Is CVE-2018-1313 being exploited?

There is no known exploitation of CVE-2018-1313 in the wild and no public exploit code.

Public exploit code:

- https://github.com/tafamace/CVE-2018-1313 (github_poc): https://github.com/tafamace/CVE-2018-1313

## Other vulnerabilities in Oracle Weblogic Server

- [CVE-2022-46337](https://insights.sbomify.com/CVE-2022-46337/): Apache Derby: LDAP injection vulnerability in authenticator (critical 9.8)
- [CVE-2015-1832](https://insights.sbomify.com/CVE-2015-1832/): Improper Restriction of XML External Entity Reference in Apace Derby (critical 9.1)
- [CVE-2010-2232](https://insights.sbomify.com/CVE-2010-2232/): Improper Access Control in Apache Derby (high 7.5)
- [CVE-2005-4849](https://insights.sbomify.com/CVE-2005-4849/): Apache Derby exposes user and password attributes (medium 5.0)
- [CVE-2006-7216](https://insights.sbomify.com/CVE-2006-7216/): Missing authorization in n/a (medium 4.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-1313 and fix it if it is affected.

What it is: CVE-2018-1313 is a medium-severity path traversal vulnerability in Oracle Weblogic Server, published on 7 May 2018. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-1313 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.derby:derby (Maven): affected from 10.3.1.4; fixed in 10.14.2.0
- org.apache.derby:derby (Maven): affected from 10.3.1.4; fixed in 10.14.2.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-1313/ (Markdown: https://insights.sbomify.com/CVE-2018-1313/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-1313
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-1313
- OSV: https://osv.dev/vulnerability/CVE-2018-1313

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-1313/
Summaries are generated and may contain mistakes; the official description above is the record.
