CVE-2018-1314 Moderate severity vulnerability that affects org.apache.hive:hive-jdbc

Medium 4.3 Published Updated

An unauthorized user can execute EXPLAIN on arbitrary tables or views to expose sensitive table metadata and statistics.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2018-1314?

CVE-2018-1314 is a medium-severity missing authorization vulnerability in Apache Hive, published on 8 Nov 2018. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

In Apache Hive 2.3.3, 3.1.0 and earlier, Hive "EXPLAIN" operation does not check for necessary authorization of involved entities in a query. An unauthorized user can do "EXPLAIN" on arbitrary table or view and expose table metadata and statistics.

Weakness: CWE-862

Which versions are affected by CVE-2018-1314?

4 open source packages ship an affected version, including org.apache.hive:hive-jdbc. It affects 1 product.

PackageAffectedFixed in
org.apache.hive:hive-jdbc MavenAll versions2.3.4
org.apache.hive:hive-jdbc MavenAll versions2.3.4
org.apache.hive:hive-jdbc MavenFrom 3.0.03.1.1
org.apache.hive:hive-jdbc MavenFrom 3.0.03.1.1

Products include Apache Hive.

How do I fix CVE-2018-1314?

Upgrade org.apache.hive:hive-jdbc to a fixed version for your release line: 2.3.4 or 3.1.1.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2018-1314 being exploited?

There is no known exploitation of CVE-2018-1314 in the wild and no public exploit code.

Sources

Also known as GHSA-jmf4-pq78-f8vj.

Is CVE-2018-1314 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free