{"answers":{"affected":"2 open source packages ship an affected version, including org.apache.ode:ode. It affects 1 product.","exploited":"There is no known exploitation of CVE-2018-1316 in the wild and no public exploit code.","fix":"Upgrade org.apache.ode:ode to 1.3.3 or later.","what":"CVE-2018-1316 is a high-severity path traversal vulnerability in Apache ODE, published on 5 Mar 2018. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2018-1316 and fix it if it is affected.\n\nWhat it is: CVE-2018-1316 is a high-severity path traversal vulnerability in Apache ODE, published on 5 Mar 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2018-1316 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.apache.ode:ode (Maven): affected all versions; fixed in 1.3.3\n- org.apache.ode:ode (Maven): affected all versions; fixed in 1.3.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2018-1316/ (Markdown: https://insights.sbomify.com/CVE-2018-1316/index.md)","id":"CVE-2018-1316","markdown":"https://insights.sbomify.com/CVE-2018-1316/index.md","name":"CVE-2018-1316","record":{"aliases":["GHSA-jf7g-5q92-4hp2"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["data_modify","denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Apache ODE","requires_auth":"none","summary":"Attackers can exploit path traversal in Apache ODE deployment service to write, overwrite, or delete files in arbitrary locations.","user_interaction":"not_required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"ode","vendor":"apache"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N","version":"3.0"},"cwes":[{"id":"CWE-22","name":"Improper Limitation of a Pathname to a Restricted Directory"}],"description":"The ODE process deployment web service was sensible to deployment messages with forged names. Using a path for the name was allowing directory traversal, resulting in the potential writing of files under unwanted locations, the overwriting of existing files or their deletion. This issue was addressed in Apache ODE 1.3.3 which was released in 2009, however the incorrect name CVE-2008-2370 was used on the advisory by mistake.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Apache ODE Path Traversal vulnerability","id":"CVE-2018-1316","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"path_traversal","year":"2018"},"n_packages":2,"n_references":2,"next":{"headline":"Improper Authentication in Apache Zeppelin","id":"CVE-2018-1317"},"packages":[{"ecosystem":"Maven","fixed":["1.3.3"],"introduced":["0"],"last_affected":[],"package":"org.apache.ode:ode","purl":null,"source":"GHSA-jf7g-5q92-4hp2"},{"ecosystem":"Maven","fixed":["1.3.3"],"introduced":["0"],"last_affected":[],"package":"org.apache.ode:ode","purl":"pkg:maven/org.apache.ode/ode","source":"GHSA-jf7g-5q92-4hp2"}],"prev":{"headline":"Incorrect Permission Assignment for Critical Resource in Apache hive","id":"CVE-2018-1315"},"products":["Apache ODE"],"published":"2018-03-05","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-17","vendors":["Apache Software Foundation"]},"summary":"Attackers can exploit path traversal in Apache ODE deployment service to write, overwrite, or delete files in arbitrary locations.","url":"https://insights.sbomify.com/CVE-2018-1316/"}