# CVE-2018-1316: Apache ODE Path Traversal vulnerability

> Attackers can exploit path traversal in Apache ODE deployment service to write, overwrite, or delete files in arbitrary locations.

- **Severity:** High 7.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 5 Mar 2018
- **Updated:** 17 Sep 2024
- **Also known as:** GHSA-jf7g-5q92-4hp2

## What is CVE-2018-1316?

CVE-2018-1316 is a high-severity path traversal vulnerability in Apache ODE, published on 5 Mar 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The ODE process deployment web service was sensible to deployment messages with forged names. Using a path for the name was allowing directory traversal, resulting in the potential writing of files under unwanted locations, the overwriting of existing files or their deletion. This issue was addressed in Apache ODE 1.3.3 which was released in 2009, however the incorrect name CVE-2008-2370 was used on the advisory by mistake.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2018-1316?

2 open source packages ship an affected version, including org.apache.ode:ode. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.ode:ode` | Maven | All versions | 1.3.3 |
| `org.apache.ode:ode` | Maven | All versions | 1.3.3 |

Products: Apache Ode.

## How do I fix CVE-2018-1316?

Upgrade org.apache.ode:ode to 1.3.3 or later.

## Is CVE-2018-1316 being exploited?

There is no known exploitation of CVE-2018-1316 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-1316 and fix it if it is affected.

What it is: CVE-2018-1316 is a high-severity path traversal vulnerability in Apache ODE, published on 5 Mar 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-1316 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.ode:ode (Maven): affected all versions; fixed in 1.3.3
- org.apache.ode:ode (Maven): affected all versions; fixed in 1.3.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-1316/ (Markdown: https://insights.sbomify.com/CVE-2018-1316/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-1316
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-1316
- OSV: https://osv.dev/vulnerability/CVE-2018-1316

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-1316/
Summaries are generated and may contain mistakes; the official description above is the record.
