CVE-2018-1318 Null dereference in Apache Traffic Server

High 7.5 Published Updated

A carefully crafted request can cause a segfault in Apache Traffic Server when method ACLs are configured, leading to denial of service.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2018-1318?

CVE-2018-1318 is a high-severity vulnerability in Apache Traffic Server, published on 29 Aug 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Adding method ACLs in remap.config can cause a segfault when the user makes a carefully crafted request. This affects versions Apache Traffic Server (ATS) 6.0.0 to 6.2.2 and 7.0.0 to 7.1.3. To resolve this issue users running 6.x should upgrade to 6.2.3 or later versions and 7.x users should upgrade to 7.1.4 or later versions.

Weakness: CWE-20

Which versions are affected by CVE-2018-1318?

It affects 2 products.

Products include Apache Traffic Server, Debian Debian Linux.

How do I fix CVE-2018-1318?

Upgrade to a fixed version.

Is CVE-2018-1318 being exploited?

There is no known exploitation of CVE-2018-1318 in the wild and no public exploit code.

All Apache Traffic Server vulnerabilities

Sources

Also known as DEBIAN-CVE-2018-1318, GHSA-3mf6-hp9h-pxf7, UBUNTU-CVE-2018-1318.

Is CVE-2018-1318 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free