# CVE-2018-1320: Improper Input Validation in Apache Thrift

> Attackers can bypass SASL authentication validation in Apache Thrift Java client if assertions are disabled, potentially allowing unauthorized access.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Jan 2019
- **Updated:** 5 Aug 2024
- **Also known as:** CLEANSTART-2026-JZ93386, CLEANSTART-2026-MM18786, CLSA-2026-1772669612, DEBIAN-CVE-2018-1320, DLA-1662-1, ECHO-a7c0-8775-208f, GHSA-wjxj-f8rg-99wx, UBUNTU-CVE-2018-1320

## What is CVE-2018-1320?

CVE-2018-1320 is a high-severity vulnerability in Debian Debian Linux, published on 7 Jan 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Apache Thrift Java client library versions 0.5.0 through 0.11.0 can bypass SASL negotiation isComplete validation in the org.apache.thrift.transport.TSaslTransport class. An assert used to determine if the SASL handshake had successfully completed could be disabled in production settings making the validation incomplete.

Weakness: CWE-295 (Improper Certificate Validation)

## Which versions are affected by CVE-2018-1320?

4 open source packages ship an affected version, including org.apache.thrift:libthrift. It affects 5 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.thrift:libthrift` | Maven | From 0.10.0 | 0.12.0 |
| `org.apache.thrift:libthrift` | Maven | From 0.10.0 | 0.12.0 |
| `org.apache.thrift:libthrift` | Maven | From 0.5.0 | 0.9.3-1 |
| `org.apache.thrift:libthrift` | Maven | From 0.5.0 | 0.9.3-1 |

Products: Apache Thrift, Debian Debian Linux, F5 Traffix Signaling Delivery Controller, Oracle Global Lifecycle Management Opatch, Oracle Nosql Database.

## How do I fix CVE-2018-1320?

Upgrade org.apache.thrift:libthrift to a fixed version for your release line: 0.12.0 or 0.9.3-1.

## Is CVE-2018-1320 being exploited?

There is no known exploitation of CVE-2018-1320 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2026-55971](https://insights.sbomify.com/CVE-2026-55971/): Apache Thrift: C++ ZLIB heap buffer overflow (write) in THeaderTransport::untransform() (critical 9.3)
- [CVE-2026-48144](https://insights.sbomify.com/CVE-2026-48144/): Apache Thrift: c_glib TLS Client Missing Hostname Verification (critical 9.1)
- [CVE-2016-5397](https://insights.sbomify.com/CVE-2016-5397/): Apache Thrift Go Library Command Injection (high 8.8)
- [CVE-2026-43871](https://insights.sbomify.com/CVE-2026-43871/): Apache Thrift, Apache Thrift, Apache Thrift, Apache Thrift: TCompactProtocol varint byte-count limit (high 8.7)
- [CVE-2026-48586](https://insights.sbomify.com/CVE-2026-48586/): Denial of service in Apache Thrift (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-1320 and fix it if it is affected.

What it is: CVE-2018-1320 is a high-severity vulnerability in Debian Debian Linux, published on 7 Jan 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-1320 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.thrift:libthrift (Maven): affected from 0.10.0; fixed in 0.12.0
- org.apache.thrift:libthrift (Maven): affected from 0.10.0; fixed in 0.12.0
- org.apache.thrift:libthrift (Maven): affected from 0.5.0; fixed in 0.9.3-1
- org.apache.thrift:libthrift (Maven): affected from 0.5.0; fixed in 0.9.3-1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-1320/ (Markdown: https://insights.sbomify.com/CVE-2018-1320/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-1320
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-1320
- OSV: https://osv.dev/vulnerability/CVE-2018-1320

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-1320/
Summaries are generated and may contain mistakes; the official description above is the record.
