CVE-2018-1321 High severity vulnerability that affects org.apache.syncope:syncope-core

High 7.2 Published Updated

Administrators with specific entitlements can exploit XSLT features to execute arbitrary code, read/write files, and compromise the system.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2018-1321?

CVE-2018-1321 is a high-severity code injection vulnerability in Apache Syncope, published on 20 Mar 2018. An attacker needs administrator access to exploit it, with no action from the victim.

Official description

An administrator with report and template entitlements in Apache Syncope 1.2.x before 1.2.11, 2.0.x before 2.0.8, and unsupported releases 1.0.x and 1.1.x which may be also affected, can use XSL Transformations (XSLT) to perform malicious operations, including but not limited to file read, file write, and code execution.

Weakness: CWE-20

Which versions are affected by CVE-2018-1321?

4 open source packages ship an affected version, including org.apache.syncope:syncope-core. It affects 1 product.

PackageAffectedFixed in
org.apache.syncope:syncope-core MavenAll versions1.2.11
org.apache.syncope:syncope-core MavenAll versions1.2.11
org.apache.syncope:syncope-core MavenFrom 2.0.02.0.8
org.apache.syncope:syncope-core MavenFrom 2.0.02.0.8

Products include Apache Syncope.

How do I fix CVE-2018-1321?

Upgrade org.apache.syncope:syncope-core to a fixed version for your release line: 1.2.11 or 2.0.8.

Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.

Is CVE-2018-1321 being exploited?

There is no known exploitation of CVE-2018-1321 in the wild and no public exploit code.

Public exploit code: 1 Exploit-DB entry.

Sources

Also known as GHSA-xgc9-9w4v-h33h.

Is CVE-2018-1321 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free