{"answers":{"affected":"4 open source packages ship an affected version, including org.apache.syncope:syncope-core. It affects 1 product.","exploited":"There is no known exploitation of CVE-2018-1321 in the wild and no public exploit code.","fix":"Upgrade org.apache.syncope:syncope-core to a fixed version for your release line: 1.2.11 or 2.0.8.","what":"CVE-2018-1321 is a high-severity code injection vulnerability in Apache Syncope, published on 20 Mar 2018. An attacker needs administrator access to exploit it, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2018-1321 and fix it if it is affected.\n\nWhat it is: CVE-2018-1321 is a high-severity code injection vulnerability in Apache Syncope, published on 20 Mar 2018. An attacker needs administrator access to exploit it, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2018-1321 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.apache.syncope:syncope-core (Maven): affected all versions; fixed in 1.2.11\n- org.apache.syncope:syncope-core (Maven): affected all versions; fixed in 1.2.11\n- org.apache.syncope:syncope-core (Maven): affected from 2.0.0; fixed in 2.0.8\n- org.apache.syncope:syncope-core (Maven): affected from 2.0.0; fixed in 2.0.8\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2018-1321/ (Markdown: https://insights.sbomify.com/CVE-2018-1321/index.md)","id":"CVE-2018-1321","markdown":"https://insights.sbomify.com/CVE-2018-1321/index.md","name":"CVE-2018-1321","record":{"aliases":["GHSA-xgc9-9w4v-h33h"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","data_read","data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"Apache Syncope","requires_auth":"high_privilege","summary":"Administrators with specific entitlements can exploit XSLT features to execute arbitrary code, read/write files, and compromise the system.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"syncope","vendor":"apache"}],"cvss":{"score":7.2,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-20","name":"Improper Input Validation"}],"description":"An administrator with report and template entitlements in Apache Syncope 1.2.x before 1.2.11, 2.0.x before 2.0.8, and unsupported releases 1.0.x and 1.1.x which may be also affected, can use XSL Transformations (XSLT) to perform malicious operations, including but not limited to file read, file write, and code execution.","ecosystems":["Maven"],"exploits":{"exploitdb":1,"first_seen":"2018-09-13","github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[{"date":"2018-09-13","kind":"exploitdb","ref":"45400","stars":null,"title":"Apache Syncope 2.0.7 - Remote Code Execution"}],"tier":"poc_unverified"},"has_fix":true,"headline":"High severity vulnerability that affects org.apache.syncope:syncope-core","id":"CVE-2018-1321","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"code_injection","year":"2018"},"n_packages":4,"n_references":3,"next":{"headline":"Exposure of Sensitive Information to an Unauthorized Actor in Apache syncope-cope","id":"CVE-2018-1322"},"packages":[{"ecosystem":"Maven","fixed":["1.2.11"],"introduced":["0"],"last_affected":[],"package":"org.apache.syncope:syncope-core","purl":null,"source":"GHSA-xgc9-9w4v-h33h"},{"ecosystem":"Maven","fixed":["1.2.11"],"introduced":["0"],"last_affected":[],"package":"org.apache.syncope:syncope-core","purl":"pkg:maven/org.apache.syncope/syncope-core","source":"GHSA-xgc9-9w4v-h33h"},{"ecosystem":"Maven","fixed":["2.0.8"],"introduced":["2.0.0"],"last_affected":[],"package":"org.apache.syncope:syncope-core","purl":null,"source":"GHSA-xgc9-9w4v-h33h"},{"ecosystem":"Maven","fixed":["2.0.8"],"introduced":["2.0.0"],"last_affected":[],"package":"org.apache.syncope:syncope-core","purl":"pkg:maven/org.apache.syncope/syncope-core","source":"GHSA-xgc9-9w4v-h33h"}],"prev":{"headline":"Improper Input Validation in Apache Thrift","id":"CVE-2018-1320"},"products":["Apache Syncope"],"published":"2018-03-20","related":[{"cvss_score":9.8,"headline":"Apache Syncope: Remote Code Execution via Flowable BPMN Groovy ScriptTask","id":"CVE-2026-53405","kev_date_added":null,"published":"2026-07-20"},{"cvss_score":9.8,"headline":"Apache Syncope: Remote Code Execution via Scripted Connector","id":"CVE-2026-53421","kev_date_added":null,"published":"2026-07-20"},{"cvss_score":9.8,"headline":"Apache Syncope: SQL injection vulnerability in Audit Events search","id":"CVE-2026-57308","kev_date_added":null,"published":"2026-07-20"},{"cvss_score":9.8,"headline":"Apache Syncope: User self-service privilege escalation","id":"CVE-2026-62183","kev_date_added":null,"published":"2026-07-20"},{"cvss_score":9.8,"headline":"Apache Syncope: RCE via Groovy Sandbox bypass","id":"CVE-2026-63071","kev_date_added":null,"published":"2026-07-20"},{"cvss_score":9.8,"headline":"Expression Language Injection in Apache Syncope","id":"CVE-2020-1959","kev_date_added":null,"published":"2020-05-04"},{"cvss_score":9.8,"headline":"Injection in Apache Syncope","id":"CVE-2020-1961","kev_date_added":null,"published":"2020-05-04"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"attribution","licence":"GPL-2.0-or-later","name":"Exploit-DB"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-16","vendors":["Apache Software Foundation"]},"summary":"Administrators with specific entitlements can exploit XSLT features to execute arbitrary code, read/write files, and compromise the system.","url":"https://insights.sbomify.com/CVE-2018-1321/"}