CVE-2018-1322 Exposure of Sensitive Information to an Unauthorized Actor in Apache syncope-cope

Medium 4.9 Published Updated

Administrators with user search entitlements can recover sensitive security values via fiql and orderby parameters in Apache Syncope.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2018-1322?

CVE-2018-1322 is a medium-severity vulnerability in Apache Syncope, published on 20 Mar 2018. An attacker needs administrator access to exploit it, with no action from the victim.

Official description

An administrator with user search entitlements in Apache Syncope 1.2.x before 1.2.11, 2.0.x before 2.0.8, and unsupported releases 1.0.x and 1.1.x which may be also affected, can recover sensitive security values using the fiql and orderby parameters.

Weakness: CWE-200

Which versions are affected by CVE-2018-1322?

4 open source packages ship an affected version, including org.apache.syncope:syncope-core. It affects 1 product.

PackageAffectedFixed in
org.apache.syncope:syncope-core MavenAll versions1.2.11
org.apache.syncope:syncope-core MavenAll versions1.2.11
org.apache.syncope:syncope-core MavenFrom 2.0.02.0.8
org.apache.syncope:syncope-core MavenFrom 2.0.02.0.8

Products include Apache Syncope.

How do I fix CVE-2018-1322?

Upgrade org.apache.syncope:syncope-core to a fixed version for your release line: 1.2.11 or 2.0.8.

Is CVE-2018-1322 being exploited?

There is no known exploitation of CVE-2018-1322 in the wild and no public exploit code.

Public exploit code: 1 Exploit-DB entry.

Sources

Also known as GHSA-v3vf-2r98-xw8w.

Is CVE-2018-1322 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free