# CVE-2018-1322: Exposure of Sensitive Information to an Unauthorized Actor in Apache syncope-cope

> Administrators with user search entitlements can recover sensitive security values via fiql and orderby parameters in Apache Syncope.

- **Severity:** Medium 4.9 (`CVSS:3.0/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Mar 2018
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-v3vf-2r98-xw8w

## What is CVE-2018-1322?

CVE-2018-1322 is a medium-severity vulnerability in Apache Syncope, published on 20 Mar 2018. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

An administrator with user search entitlements in Apache Syncope 1.2.x before 1.2.11, 2.0.x before 2.0.8, and unsupported releases 1.0.x and 1.1.x which may be also affected, can recover sensitive security values using the fiql and orderby parameters.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2018-1322?

4 open source packages ship an affected version, including org.apache.syncope:syncope-core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.syncope:syncope-core` | Maven | All versions | 1.2.11 |
| `org.apache.syncope:syncope-core` | Maven | All versions | 1.2.11 |
| `org.apache.syncope:syncope-core` | Maven | From 2.0.0 | 2.0.8 |
| `org.apache.syncope:syncope-core` | Maven | From 2.0.0 | 2.0.8 |

Products: Apache Syncope.

## How do I fix CVE-2018-1322?

Upgrade org.apache.syncope:syncope-core to a fixed version for your release line: 1.2.11 or 2.0.8.

## Is CVE-2018-1322 being exploited?

There is no known exploitation of CVE-2018-1322 in the wild and no public exploit code.

Public exploit code:

- Apache Syncope 2.0.7 - Remote Code Execution (exploitdb)

## Other vulnerabilities in Apache Syncope

- [CVE-2026-53405](https://insights.sbomify.com/CVE-2026-53405/): Apache Syncope: Remote Code Execution via Flowable BPMN Groovy ScriptTask (critical 9.8)
- [CVE-2026-53421](https://insights.sbomify.com/CVE-2026-53421/): Apache Syncope: Remote Code Execution via Scripted Connector (critical 9.8)
- [CVE-2026-57308](https://insights.sbomify.com/CVE-2026-57308/): Apache Syncope: SQL injection vulnerability in Audit Events search (critical 9.8)
- [CVE-2026-62183](https://insights.sbomify.com/CVE-2026-62183/): Apache Syncope: User self-service privilege escalation (critical 9.8)
- [CVE-2026-63071](https://insights.sbomify.com/CVE-2026-63071/): Apache Syncope: RCE via Groovy Sandbox bypass (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-1322 and fix it if it is affected.

What it is: CVE-2018-1322 is a medium-severity vulnerability in Apache Syncope, published on 20 Mar 2018. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-1322 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.syncope:syncope-core (Maven): affected all versions; fixed in 1.2.11
- org.apache.syncope:syncope-core (Maven): affected all versions; fixed in 1.2.11
- org.apache.syncope:syncope-core (Maven): affected from 2.0.0; fixed in 2.0.8
- org.apache.syncope:syncope-core (Maven): affected from 2.0.0; fixed in 2.0.8

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-1322/ (Markdown: https://insights.sbomify.com/CVE-2018-1322/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-1322
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-1322
- OSV: https://osv.dev/vulnerability/CVE-2018-1322

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-1322/
Summaries are generated and may contain mistakes; the official description above is the record.
