CVE-2018-1325 Cross-site Scripting in wicket-jquery-ui
Attackers can execute arbitrary JavaScript via WYSIWYG editor content in Apache wicket-jquery-ui, potentially compromising user sessions.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2018-1325?
CVE-2018-1325 is a medium-severity cross-site scripting vulnerability in Apache Software Foundation wicket-jquery-ui, published on 18 Apr 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
In Apache wicket-jquery-ui <= 6.29.0, <= 7.10.1, <= 8.0.0-M9.1, JS code created in WYSIWYG editor will be executed on display.
Weakness: CWE-79
Which versions are affected by CVE-2018-1325?
6 open source packages ship an affected version, including com.googlecode.wicket-jquery-ui:wicket-jquery-ui-parent. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
com.googlecode.wicket-jquery-ui:wicket-jquery-ui-parent Maven | All versions | 6.29.1 |
com.googlecode.wicket-jquery-ui:wicket-jquery-ui-parent Maven | All versions | 6.29.1 |
com.googlecode.wicket-jquery-ui:wicket-jquery-ui-parent Maven | From 7.0.0 | 7.10.2 |
com.googlecode.wicket-jquery-ui:wicket-jquery-ui-parent Maven | From 7.0.0 | 7.10.2 |
com.googlecode.wicket-jquery-ui:wicket-jquery-ui-parent Maven | From 8.0.0-M1 | 8.0.0-M9.2 |
com.googlecode.wicket-jquery-ui:wicket-jquery-ui-parent Maven | From 8.0.0-M1 | 8.0.0-M9.2 |
Products include Wicket-Jquery-Ui Project Wicket-Jquery-Ui.
How do I fix CVE-2018-1325?
Upgrade com.googlecode.wicket-jquery-ui:wicket-jquery-ui-parent to a fixed version for your release line: 6.29.1, 7.10.2 or 8.0.0-M9.2.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2018-1325 being exploited?
There is no known exploitation of CVE-2018-1325 in the wild and no public exploit code.
Other vulnerabilities in Apache Software Foundation wicket-jquery-ui
Sources
Also known as GHSA-pjv3-rh6v-2pj8.