CVE-2018-1327 Apache Struts REST Plugin can potentially allow a DoS attack

High 7.5 Published Updated

Attackers can cause denial of service in Apache Struts REST Plugin via malicious XML payloads processed by the vulnerable XStream library.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2018-1327?

CVE-2018-1327 is a high-severity denial of service vulnerability in Apache Struts, published on 27 Mar 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

The Apache Struts REST Plugin is using XStream library which is vulnerable and allow perform a DoS attack when using a malicious request with specially crafted XML payload. Upgrade to the Apache Struts version 2.5.16 and switch to an optional Jackson XML handler as described here http://struts.apache.org/plugins/rest/#custom-contenttypehandlers. Another option is to implement a custom XML handler based on the Jackson XML handler from the Apache Struts 2.5.16.

Which versions are affected by CVE-2018-1327?

2 open source packages ship an affected version, including org.apache.struts:struts2-rest-plugin. It affects 1 product.

PackageAffectedFixed in
org.apache.struts:struts2-rest-plugin MavenFrom 2.1.12.5.16
org.apache.struts:struts2-rest-plugin MavenFrom 2.1.12.5.16

Products include Apache Struts.

How do I fix CVE-2018-1327?

Upgrade org.apache.struts:struts2-rest-plugin to 2.5.16 or later.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2018-1327 being exploited?

There is no known exploitation of CVE-2018-1327 in the wild and no public exploit code.

All Apache Struts vulnerabilities

Sources

Also known as GHSA-38cr-2ph5-frr9.

Is CVE-2018-1327 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free