# CVE-2018-1327: Apache Struts REST Plugin can potentially allow a DoS attack

> Attackers can cause denial of service in Apache Struts REST Plugin via malicious XML payloads processed by the vulnerable XStream library.

- **Severity:** High 7.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 Mar 2018
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-38cr-2ph5-frr9

## What is CVE-2018-1327?

CVE-2018-1327 is a high-severity denial of service vulnerability in Apache Struts, published on 27 Mar 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The Apache Struts REST Plugin is using XStream library which is vulnerable and allow perform a DoS attack when using a malicious request with specially crafted XML payload. Upgrade to the Apache Struts version 2.5.16 and switch to an optional Jackson XML handler as described here http://struts.apache.org/plugins/rest/#custom-contenttypehandlers. Another option is to implement a custom XML handler based on the Jackson XML handler from the Apache Struts 2.5.16.

## Which versions are affected by CVE-2018-1327?

2 open source packages ship an affected version, including org.apache.struts:struts2-rest-plugin. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.struts:struts2-rest-plugin` | Maven | From 2.1.1 | 2.5.16 |
| `org.apache.struts:struts2-rest-plugin` | Maven | From 2.1.1 | 2.5.16 |

Products: Apache Struts.

## How do I fix CVE-2018-1327?

Upgrade org.apache.struts:struts2-rest-plugin to 2.5.16 or later.

## Is CVE-2018-1327 being exploited?

There is no known exploitation of CVE-2018-1327 in the wild and no public exploit code.

## Other vulnerabilities in Apache Struts

- [CVE-2020-17530](https://insights.sbomify.com/CVE-2020-17530/): Apache Struts Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2017-9791](https://insights.sbomify.com/CVE-2017-9791/): Apache Struts 1 Improper Input Validation (critical 9.8, exploited in the wild)
- [CVE-2017-5638](https://insights.sbomify.com/CVE-2017-5638/): Apache Struts Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2012-0391](https://insights.sbomify.com/CVE-2012-0391/): Apache Struts 2 Improper Input Validation (critical 9.8, exploited in the wild)
- [CVE-2018-11776](https://insights.sbomify.com/CVE-2018-11776/): Apache Struts Remote Code Execution (high 8.1, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-1327 and fix it if it is affected.

What it is: CVE-2018-1327 is a high-severity denial of service vulnerability in Apache Struts, published on 27 Mar 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-1327 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.struts:struts2-rest-plugin (Maven): affected from 2.1.1; fixed in 2.5.16
- org.apache.struts:struts2-rest-plugin (Maven): affected from 2.1.1; fixed in 2.5.16

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-1327/ (Markdown: https://insights.sbomify.com/CVE-2018-1327/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-1327
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-1327
- OSV: https://osv.dev/vulnerability/CVE-2018-1327

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-1327/
Summaries are generated and may contain mistakes; the official description above is the record.
