{"answers":{"affected":"2 open source packages ship an affected version, including org.apache.zeppelin:zeppelin. It affects 1 product.","exploited":"There is no known exploitation of CVE-2018-1328 in the wild and no public exploit code.","fix":"Upgrade org.apache.zeppelin:zeppelin to 0.8.0 or later.","what":"CVE-2018-1328 is a medium-severity cross-site scripting vulnerability in Apache Zeppelin, published on 23 Apr 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2018-1328 and fix it if it is affected.\n\nWhat it is: CVE-2018-1328 is a medium-severity cross-site scripting vulnerability in Apache Zeppelin, published on 23 Apr 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2018-1328 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.apache.zeppelin:zeppelin (Maven): affected all versions; fixed in 0.8.0\n- org.apache.zeppelin:zeppelin (Maven): affected all versions; fixed in 0.8.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2018-1328/ (Markdown: https://insights.sbomify.com/CVE-2018-1328/index.md)","id":"CVE-2018-1328","markdown":"https://insights.sbomify.com/CVE-2018-1328/index.md","name":"CVE-2018-1328","record":{"aliases":["GHSA-r2v5-5vcr-h3vq"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Apache Zeppelin","requires_auth":"none","summary":"An attacker can inject malicious scripts into Apache Zeppelin notes, potentially executing code or hijacking user sessions.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"zeppelin","vendor":"apache"}],"cvss":{"score":6.1,"severity":"medium","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Apache Zeppelin prior to 0.8.0 had a stored XSS issue via Note permissions. Issue reported by \"Josna Joseph\".","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Cross-site Scripting in Apache Zeppelin","id":"CVE-2018-1328","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"xss","year":"2018"},"n_packages":2,"n_references":4,"next":{"headline":"DO NOT USE THIS CANDIDATE NUMBER.","id":"CVE-2018-1329"},"packages":[{"ecosystem":"Maven","fixed":["0.8.0"],"introduced":["0"],"last_affected":[],"package":"org.apache.zeppelin:zeppelin","purl":null,"source":"GHSA-r2v5-5vcr-h3vq"},{"ecosystem":"Maven","fixed":["0.8.0"],"introduced":["0"],"last_affected":[],"package":"org.apache.zeppelin:zeppelin","purl":"pkg:maven/org.apache.zeppelin/zeppelin","source":"GHSA-r2v5-5vcr-h3vq"}],"prev":{"headline":"Apache Struts REST Plugin can potentially allow a DoS attack","id":"CVE-2018-1327"},"products":["Apache Zeppelin"],"published":"2019-04-23","related":[{"cvss_score":9.8,"headline":"Apache Zeppelin: Remote code execution by adding malicious JDBC connection string","id":"CVE-2024-31864","kev_date_added":null,"published":"2024-04-09"},{"cvss_score":9.8,"headline":"Apache Zeppelin: Interpreter download command does not escape malicious code injection","id":"CVE-2024-31866","kev_date_added":null,"published":"2024-04-09"},{"cvss_score":9.8,"headline":"bash command injection in spark interpreter","id":"CVE-2019-10095","kev_date_added":null,"published":"2021-09-02"},{"cvss_score":8.8,"headline":"Improper Authentication in Apache Zeppelin","id":"CVE-2018-1317","kev_date_added":null,"published":"2019-04-23"},{"cvss_score":8.1,"headline":"Session Fixation in Apache Zeppelin","id":"CVE-2017-12619","kev_date_added":null,"published":"2019-04-23"},{"cvss_score":7.5,"headline":"Apache Zeppelin: Command Injection via CSWSH","id":"CVE-2024-51775","kev_date_added":null,"published":"2025-08-03"},{"cvss_score":7.5,"headline":"Apache Zeppelin: Arbitrary file read by adding malicious JDBC connection string","id":"CVE-2024-52279","kev_date_added":null,"published":"2025-08-03"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["Apache Software Foundation"]},"summary":"An attacker can inject malicious scripts into Apache Zeppelin notes, potentially executing code or hijacking user sessions.","url":"https://insights.sbomify.com/CVE-2018-1328/"}