CVE-2018-1331 Code execution in org.apache.storm:storm-core
An attacker with access to a secure Apache Storm cluster can execute arbitrary code as a different user, leading to privilege escalation.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2018-1331?
CVE-2018-1331 is a high-severity vulnerability in Apache Storm, published on 10 Jul 2018. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
In Apache Storm 0.10.0 through 0.10.2, 1.0.0 through 1.0.6, 1.1.0 through 1.1.2, and 1.2.0 through 1.2.1, an attacker with access to a secure storm cluster in some cases could execute arbitrary code as a different user.
Which versions are affected by CVE-2018-1331?
4 open source packages ship an affected version, including org.apache.storm:storm-core. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.apache.storm:storm-core Maven | All versions | 1.1.3 |
org.apache.storm:storm-core Maven | All versions | 1.1.3 |
org.apache.storm:storm-core Maven | From 1.2.0 | 1.2.2 |
org.apache.storm:storm-core Maven | From 1.2.0 | 1.2.2 |
Products include Apache Storm.
How do I fix CVE-2018-1331?
Upgrade org.apache.storm:storm-core to a fixed version for your release line: 1.1.3 or 1.2.2.
Is CVE-2018-1331 being exploited?
There is no known exploitation of CVE-2018-1331 in the wild and no public exploit code.
Other vulnerabilities in Apache Storm
- CVE-2021-38294 Shell Command Injection Vulnerability in Nimbus Thrift Server
- CVE-2021-40865 Unsafe Pre-Authentication Deserialization In Workers
- CVE-2018-11779 Deserialization of Untrusted Data in Apache Storm
- CVE-2015-3188 Apache Storm remote code execution vulnerability
- CVE-2026-35337 Apache Storm Client: RCE through Unsafe Deserialization via Kerberos TGT Credential Handling
Sources
Also known as GHSA-p8jx-x2vw-wm33.