# CVE-2018-1331: Code execution in org.apache.storm:storm-core

> An attacker with access to a secure Apache Storm cluster can execute arbitrary code as a different user, leading to privilege escalation.

- **Severity:** High 8.8 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Jul 2018
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-p8jx-x2vw-wm33

## What is CVE-2018-1331?

CVE-2018-1331 is a high-severity vulnerability in Apache Storm, published on 10 Jul 2018. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

In Apache Storm 0.10.0 through 0.10.2, 1.0.0 through 1.0.6, 1.1.0 through 1.1.2, and 1.2.0 through 1.2.1, an attacker with access to a secure storm cluster in some cases could execute arbitrary code as a different user.

## Which versions are affected by CVE-2018-1331?

4 open source packages ship an affected version, including org.apache.storm:storm-core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.storm:storm-core` | Maven | All versions | 1.1.3 |
| `org.apache.storm:storm-core` | Maven | All versions | 1.1.3 |
| `org.apache.storm:storm-core` | Maven | From 1.2.0 | 1.2.2 |
| `org.apache.storm:storm-core` | Maven | From 1.2.0 | 1.2.2 |

Products: Apache Storm.

## How do I fix CVE-2018-1331?

Upgrade org.apache.storm:storm-core to a fixed version for your release line: 1.1.3 or 1.2.2.

## Is CVE-2018-1331 being exploited?

There is no known exploitation of CVE-2018-1331 in the wild and no public exploit code.

## Other vulnerabilities in Apache Storm

- [CVE-2021-38294](https://insights.sbomify.com/CVE-2021-38294/): Shell Command Injection Vulnerability in Nimbus Thrift Server (critical 9.8)
- [CVE-2021-40865](https://insights.sbomify.com/CVE-2021-40865/): Unsafe Pre-Authentication Deserialization In Workers (critical 9.8)
- [CVE-2018-11779](https://insights.sbomify.com/CVE-2018-11779/): Deserialization of Untrusted Data in Apache Storm (critical 9.8)
- [CVE-2015-3188](https://insights.sbomify.com/CVE-2015-3188/): Apache Storm remote code execution vulnerability (critical 9.8)
- [CVE-2026-35337](https://insights.sbomify.com/CVE-2026-35337/): Apache Storm Client: RCE through Unsafe Deserialization via Kerberos TGT Credential Handling (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-1331 and fix it if it is affected.

What it is: CVE-2018-1331 is a high-severity vulnerability in Apache Storm, published on 10 Jul 2018. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-1331 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.storm:storm-core (Maven): affected all versions; fixed in 1.1.3
- org.apache.storm:storm-core (Maven): affected all versions; fixed in 1.1.3
- org.apache.storm:storm-core (Maven): affected from 1.2.0; fixed in 1.2.2
- org.apache.storm:storm-core (Maven): affected from 1.2.0; fixed in 1.2.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-1331/ (Markdown: https://insights.sbomify.com/CVE-2018-1331/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-1331
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-1331
- OSV: https://osv.dev/vulnerability/CVE-2018-1331

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-1331/
Summaries are generated and may contain mistakes; the official description above is the record.
