CVE-2018-1332 Moderate severity vulnerability that affects org.apache.storm:storm-core

Medium 6.5 Published Updated

Attackers can impersonate other users when communicating with Storm Daemons, leading to unauthorized access and privilege escalation.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2018-1332?

CVE-2018-1332 is a medium-severity authentication bypass vulnerability in Apache Storm, published on 5 Jun 2018. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

Apache Storm version 1.0.6 and earlier, 1.2.1 and earlier, and version 1.1.2 and earlier expose a vulnerability that could allow a user to impersonate another user when communicating with some Storm Daemons.

Weakness: CWE-200

Which versions are affected by CVE-2018-1332?

4 open source packages ship an affected version, including org.apache.storm:storm-core. It affects 1 product.

PackageAffectedFixed in
org.apache.storm:storm-core MavenAll versions1.1.3
org.apache.storm:storm-core MavenAll versions1.1.3
org.apache.storm:storm-core MavenFrom 1.2.01.2.2
org.apache.storm:storm-core MavenFrom 1.2.01.2.2

Products include Apache Storm.

How do I fix CVE-2018-1332?

Upgrade org.apache.storm:storm-core to a fixed version for your release line: 1.1.3 or 1.2.2.

Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.

Is CVE-2018-1332 being exploited?

There is no known exploitation of CVE-2018-1332 in the wild and no public exploit code.

Sources

Also known as GHSA-q35p-chc6-7x57.

Is CVE-2018-1332 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free