# CVE-2018-1332: Moderate severity vulnerability that affects org.apache.storm:storm-core

> Attackers can impersonate other users when communicating with Storm Daemons, leading to unauthorized access and privilege escalation.

- **Severity:** Medium 6.5 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 5 Jun 2018
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-q35p-chc6-7x57

## What is CVE-2018-1332?

CVE-2018-1332 is a medium-severity authentication bypass vulnerability in Apache Storm, published on 5 Jun 2018. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Apache Storm version 1.0.6 and earlier, 1.2.1 and earlier, and version 1.1.2 and earlier expose a vulnerability that could allow a user to impersonate another user when communicating with some Storm Daemons.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2018-1332?

4 open source packages ship an affected version, including org.apache.storm:storm-core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.storm:storm-core` | Maven | All versions | 1.1.3 |
| `org.apache.storm:storm-core` | Maven | All versions | 1.1.3 |
| `org.apache.storm:storm-core` | Maven | From 1.2.0 | 1.2.2 |
| `org.apache.storm:storm-core` | Maven | From 1.2.0 | 1.2.2 |

Products: Apache Storm.

## How do I fix CVE-2018-1332?

Upgrade org.apache.storm:storm-core to a fixed version for your release line: 1.1.3 or 1.2.2.

## Is CVE-2018-1332 being exploited?

There is no known exploitation of CVE-2018-1332 in the wild and no public exploit code.

## Other vulnerabilities in Apache Storm

- [CVE-2021-38294](https://insights.sbomify.com/CVE-2021-38294/): Shell Command Injection Vulnerability in Nimbus Thrift Server (critical 9.8)
- [CVE-2021-40865](https://insights.sbomify.com/CVE-2021-40865/): Unsafe Pre-Authentication Deserialization In Workers (critical 9.8)
- [CVE-2018-11779](https://insights.sbomify.com/CVE-2018-11779/): Deserialization of Untrusted Data in Apache Storm (critical 9.8)
- [CVE-2015-3188](https://insights.sbomify.com/CVE-2015-3188/): Apache Storm remote code execution vulnerability (critical 9.8)
- [CVE-2026-35337](https://insights.sbomify.com/CVE-2026-35337/): Apache Storm Client: RCE through Unsafe Deserialization via Kerberos TGT Credential Handling (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-1332 and fix it if it is affected.

What it is: CVE-2018-1332 is a medium-severity authentication bypass vulnerability in Apache Storm, published on 5 Jun 2018. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-1332 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.storm:storm-core (Maven): affected all versions; fixed in 1.1.3
- org.apache.storm:storm-core (Maven): affected all versions; fixed in 1.1.3
- org.apache.storm:storm-core (Maven): affected from 1.2.0; fixed in 1.2.2
- org.apache.storm:storm-core (Maven): affected from 1.2.0; fixed in 1.2.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-1332/ (Markdown: https://insights.sbomify.com/CVE-2018-1332/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-1332
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-1332
- OSV: https://osv.dev/vulnerability/CVE-2018-1332

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-1332/
Summaries are generated and may contain mistakes; the official description above is the record.
