# CVE-2018-13347: Mercurial mishandles integer addition and subtraction


- **Severity:** Critical 9.8 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 6 Jul 2018
- **Updated:** 5 Aug 2024
- **Also known as:** DEBIAN-CVE-2018-13347, GHSA-3mjj-mr4f-qxmx, PYSEC-2018-89, UBUNTU-CVE-2018-13347

## What is CVE-2018-13347?

CVE-2018-13347 is a critical vulnerability in n/a, published on 6 Jul 2018. 

### Official description

mpatch.c in Mercurial before 4.6.1 mishandles integer addition and subtraction, aka OVE-20180430-0002.

Weakness: CWE-190 (Integer Overflow or Wraparound)

## Which versions are affected by CVE-2018-13347?

3 open source packages ship an affected version, including mercurial. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mercurial` | PyPI | All versions | 4.6.1 |
| `mercurial` | PyPI | All versions | 4.6.1 |
| `mercurial` | PyPI | All versions | 4.6.1 |

Products: Mercurial Mercurial.

## How do I fix CVE-2018-13347?

Upgrade mercurial to 4.6.1 or later.

## Is CVE-2018-13347 being exploited?

There is no known exploitation of CVE-2018-13347 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2018-17983](https://insights.sbomify.com/CVE-2018-17983/): Mercurial Out-of-bounds Read vulnerability (critical 9.1)
- [CVE-2018-13346](https://insights.sbomify.com/CVE-2018-13346/): Mercurial Improper Input Validation vulnerability (high 7.5)
- [CVE-2018-13348](https://insights.sbomify.com/CVE-2018-13348/): Mercurial Improper Input Validation vulnerability (high 7.5)
- [CVE-2014-9462](https://insights.sbomify.com/CVE-2014-9462/): Mercurial vulnerable to arbitrary command execution via a crafted repository name in a clone command (high 7.5)
- [CVE-2008-2942](https://insights.sbomify.com/CVE-2008-2942/): Mercurial Directory traversal vulnerability (medium 6.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-13347 and fix it if it is affected.

What it is: CVE-2018-13347 is a critical vulnerability in n/a, published on 6 Jul 2018. 
Exploitation: There is no known exploitation of CVE-2018-13347 in the wild and no public exploit code.

Affected packages and fixed versions:
- mercurial (PyPI): affected all versions; fixed in 4.6.1
- mercurial (PyPI): affected all versions; fixed in 4.6.1
- mercurial (PyPI): affected all versions; fixed in 4.6.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-13347/ (Markdown: https://insights.sbomify.com/CVE-2018-13347/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-13347
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-13347
- OSV: https://osv.dev/vulnerability/CVE-2018-13347

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-13347/
Summaries are generated and may contain mistakes; the official description above is the record.
