{"answers":{"affected":"3 open source packages ship an affected version, including mercurial. It affects 1 product.","exploited":"There is no known exploitation of CVE-2018-13348 in the wild and no public exploit code.","fix":"Upgrade mercurial to 4.6.1 or later.","what":"CVE-2018-13348 is a high-severity vulnerability in n/a, published on 6 Jul 2018. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2018-13348 and fix it if it is affected.\n\nWhat it is: CVE-2018-13348 is a high-severity vulnerability in n/a, published on 6 Jul 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2018-13348 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- mercurial (PyPI): affected all versions; fixed in 4.6.1\n- mercurial (PyPI): affected all versions; fixed in 4.6.1\n- mercurial (PyPI): affected all versions; fixed in 4.6.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2018-13348/ (Markdown: https://insights.sbomify.com/CVE-2018-13348/index.md)","id":"CVE-2018-13348","markdown":"https://insights.sbomify.com/CVE-2018-13348/index.md","name":"CVE-2018-13348","record":{"aliases":["DEBIAN-CVE-2018-13348","GHSA-3v62-ww8w-758m","PYSEC-2018-90","UBUNTU-CVE-2018-13348"],"analysis":{"component_type":"developer_tool","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Mercurial version control","requires_auth":"none","summary":"A flaw in Mercurial's patch decoding allows attackers to cause a denial of service via malformed patch data.","user_interaction":"not_required","vuln_class":"integer_overflow"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"mercurial","vendor":"mercurial"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N","version":"3.0"},"cwes":[{"id":"CWE-20","name":"Improper Input Validation"}],"description":"The mpatch_decode function in mpatch.c in Mercurial before 4.6.1 mishandles certain situations where there should be at least 12 bytes remaining after the current position in the patch data, but actually are not, aka OVE-20180430-0001.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Mercurial Improper Input Validation vulnerability","id":"CVE-2018-13348","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"integer_overflow","year":"2018"},"n_packages":3,"n_references":3,"next":{"headline":"Cross-site scripting in n/a","id":"CVE-2018-13349"},"packages":[{"ecosystem":"PyPI","fixed":["4.6.1"],"introduced":["0"],"last_affected":[],"package":"mercurial","purl":null,"source":"GHSA-3v62-ww8w-758m"},{"ecosystem":"PyPI","fixed":["4.6.1"],"introduced":["0"],"last_affected":[],"package":"mercurial","purl":"pkg:pypi/mercurial","source":"GHSA-3v62-ww8w-758m"},{"ecosystem":"PyPI","fixed":["4.6.1"],"introduced":["0"],"last_affected":[],"package":"mercurial","purl":"pkg:pypi/mercurial","source":"PYSEC-2018-90"}],"prev":{"headline":"Mercurial mishandles integer addition and subtraction","id":"CVE-2018-13347"},"products":["n/a"],"published":"2018-07-06","related":[{"cvss_score":9.8,"headline":"Mercurial mishandles integer addition and subtraction","id":"CVE-2018-13347","kev_date_added":null,"published":"2018-07-06"},{"cvss_score":9.1,"headline":"Mercurial Out-of-bounds Read vulnerability","id":"CVE-2018-17983","kev_date_added":null,"published":"2018-10-04"},{"cvss_score":7.5,"headline":"Mercurial Improper Input Validation vulnerability","id":"CVE-2018-13346","kev_date_added":null,"published":"2018-07-06"},{"cvss_score":7.5,"headline":"Mercurial vulnerable to arbitrary command execution via a crafted repository name in a clone command","id":"CVE-2014-9462","kev_date_added":null,"published":"2015-03-31"},{"cvss_score":6.8,"headline":"Mercurial Directory traversal vulnerability","id":"CVE-2008-2942","kev_date_added":null,"published":"2008-06-30"},{"cvss_score":5.9,"headline":"Mercurial Improper Certificate Validation vulnerability","id":"CVE-2010-4237","kev_date_added":null,"published":"2019-10-29"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"A flaw in Mercurial's patch decoding allows attackers to cause a denial of service via malformed patch data.","url":"https://insights.sbomify.com/CVE-2018-13348/"}