# CVE-2018-1335: Command injection in org.apache.tika:tika-core

> Attackers can inject commands into the tika-server command line via crafted headers, requiring the server to be exposed to untrusted clients.

- **Severity:** High 8.1 (`CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Apr 2018
- **Updated:** 17 Sep 2024
- **Also known as:** DEBIAN-CVE-2018-1335, GHSA-9r24-gp44-h3pm, UBUNTU-CVE-2018-1335

## What is CVE-2018-1335?

CVE-2018-1335 is a high-severity command injection vulnerability in Apache Tika, published on 25 Apr 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

From Apache Tika versions 1.7 to 1.17, clients could send carefully crafted headers to tika-server that could be used to inject commands into the command line of the server running tika-server. This vulnerability only affects those running tika-server on a server that is open to untrusted clients. The mitigation is to upgrade to Tika 1.18.

## Which versions are affected by CVE-2018-1335?

2 open source packages ship an affected version, including org.apache.tika:tika-core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.tika:tika-core` | Maven | From 1.7 | 1.18 |
| `org.apache.tika:tika-core` | Maven | From 1.7 | 1.18 |

Products: Apache Tika.

## How do I fix CVE-2018-1335?

Upgrade org.apache.tika:tika-core to 1.18 or later.

## Is CVE-2018-1335 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2018-1335 exists.

Public exploit code:

- GUI版 EXP (github_poc): https://github.com/SkyBlueEternal/CVE-2018-1335-EXP-GUI
- CENG 325 - Principles of Information Security And Privacy (github_poc): https://github.com/canumay/cve-2018-1335
- Apache Tika Header Command Injection (metasploit)
- Apache Tika-server < 1.18 - Command Injection (exploitdb)
- Apache Tika 1.15 - 1.17 - Header Command Injection (Metasploit) (exploitdb)
- https://github.com/N0b1e6/CVE-2018-1335-Python3 (github_poc): https://github.com/N0b1e6/CVE-2018-1335-Python3

## Other vulnerabilities in Apache Tika

- [CVE-2019-10088](https://insights.sbomify.com/CVE-2019-10088/): Allocation of Resources Without Limits or Throttling in Apache Tika (high 8.8)
- [CVE-2025-66516](https://insights.sbomify.com/CVE-2025-66516/): Apache Tika has XXE vulnerability (high 8.4)
- [CVE-2025-54988](https://insights.sbomify.com/CVE-2025-54988/): Apache Tika PDF parser module: XXE vulnerability in PDFParser's handling of XFA (high 8.4)
- [CVE-2019-10094](https://insights.sbomify.com/CVE-2019-10094/): Allocation of Resources Without Limits or Throttling in Apache Tika (high 7.8)
- [CVE-2016-4434](https://insights.sbomify.com/CVE-2016-4434/): Apache Tika does not properly initialize the XML parser or choose handlers (high 7.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-1335 and fix it if it is affected.

What it is: CVE-2018-1335 is a high-severity command injection vulnerability in Apache Tika, published on 25 Apr 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2018-1335 exists.

Affected packages and fixed versions:
- org.apache.tika:tika-core (Maven): affected from 1.7; fixed in 1.18
- org.apache.tika:tika-core (Maven): affected from 1.7; fixed in 1.18

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-1335/ (Markdown: https://insights.sbomify.com/CVE-2018-1335/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-1335
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-1335
- OSV: https://osv.dev/vulnerability/CVE-2018-1335

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-1335/
Summaries are generated and may contain mistakes; the official description above is the record.
