# CVE-2018-1337: Credential leak in org.apache.directory.api:apache-ldap-api

> A race condition in the SSL filter allows attackers to read sensitive data, including credentials, from pooled connections before TLS is established.

- **Severity:** Critical 9.8 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Jul 2018
- **Updated:** 17 Sep 2024
- **Also known as:** DEBIAN-CVE-2018-1337, GHSA-cfw5-v7cw-69cw

## What is CVE-2018-1337?

CVE-2018-1337 is a critical vulnerability in Apache Directory, published on 10 Jul 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

In Apache Directory LDAP API before 1.0.2, a bug in the way the SSL Filter was setup made it possible for another thread to use the connection before the TLS layer has been established, if the connection has already been used and put back in a pool of connections, leading to leaking any information contained in this request (including the credentials when sending a BIND request).

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2018-1337?

2 open source packages ship an affected version, including org.apache.directory.api:apache-ldap-api. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.directory.api:apache-ldap-api` | Maven | All versions | 1.0.2 |
| `org.apache.directory.api:apache-ldap-api` | Maven | All versions | 1.0.2 |

Products: Apache Directory Ldap Api.

## How do I fix CVE-2018-1337?

Upgrade org.apache.directory.api:apache-ldap-api to 1.0.2 or later.

## Is CVE-2018-1337 being exploited?

There is no known exploitation of CVE-2018-1337 in the wild and no public exploit code.

## Other vulnerabilities in Apache Directory

- [CVE-2026-35563](https://insights.sbomify.com/CVE-2026-35563/): Apache Directory LDAP API lacks server certificate verification for LDAP hostnames (high 8.8)
- [CVE-2015-3250](https://insights.sbomify.com/CVE-2015-3250/): Exposure of Sensitive Information to an Unauthorized Actor in Apache Directory LDAP API (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-1337 and fix it if it is affected.

What it is: CVE-2018-1337 is a critical vulnerability in Apache Directory, published on 10 Jul 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-1337 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.directory.api:apache-ldap-api (Maven): affected all versions; fixed in 1.0.2
- org.apache.directory.api:apache-ldap-api (Maven): affected all versions; fixed in 1.0.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-1337/ (Markdown: https://insights.sbomify.com/CVE-2018-1337/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-1337
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-1337
- OSV: https://osv.dev/vulnerability/CVE-2018-1337

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-1337/
Summaries are generated and may contain mistakes; the official description above is the record.
