CVE-2018-13390 Cloudtoken Insufficiently Protects Credentials
Medium 6.1
Published
Updated
Check this codebase for CVE-2018-13390 and fix it if it is affected.
What it is: CVE-2018-13390 is a medium-severity vulnerability in Atlassian cloudtoken, published on 10 Aug 2018.
Exploitation: There is no known exploitation of CVE-2018-13390 in the wild and no public exploit code.
Affected packages and fixed versions:
- cloudtoken (PyPI): affected from 0.1.1; fixed in 0.1.24
- cloudtoken (PyPI): affected from 0.1.1; fixed in 0.1.24
- cloudtoken (PyPI): affected from 0.1.1; fixed in 0.1.24
Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.
Reference: https://insights.sbomify.com/CVE-2018-13390/ (Markdown: https://insights.sbomify.com/CVE-2018-13390/index.md)
- Exploited in the wild
- Not known
- Fix
- Available
What is CVE-2018-13390?
CVE-2018-13390 is a medium-severity vulnerability in Atlassian cloudtoken, published on 10 Aug 2018.
Official description
Unauthenticated access to cloudtoken daemon on Linux via network from version 0.1.1 before version 0.1.24 allows attackers on the same subnet to gain temporary AWS credentials for the users' roles.
Which versions are affected by CVE-2018-13390?
3 open source packages ship an affected version, including cloudtoken. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
cloudtoken PyPI | From 0.1.1 | 0.1.24 |
cloudtoken PyPI | From 0.1.1 | 0.1.24 |
cloudtoken PyPI | From 0.1.1 | 0.1.24 |
Products include Atlassian Cloudtoken.
How do I fix CVE-2018-13390?
Upgrade cloudtoken to 0.1.24 or later.
Is CVE-2018-13390 being exploited?
There is no known exploitation of CVE-2018-13390 in the wild and no public exploit code.
Sources
Also known as GHSA-4fpg-j5mp-783g, PYSEC-2018-1.