{"answers":{"affected":"2 open source packages ship an affected version, including org.apache.guacamole:guacamole-common. It affects 1 product.","exploited":"There is no known exploitation of CVE-2018-1340 in the wild and no public exploit code.","fix":"Upgrade org.apache.guacamole:guacamole-common to 1.0.0 or later.","what":"CVE-2018-1340 is a high-severity vulnerability in Apache Guacamole, published on 7 Feb 2019. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2018-1340 and fix it if it is affected.\n\nWhat it is: CVE-2018-1340 is a high-severity vulnerability in Apache Guacamole, published on 7 Feb 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2018-1340 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.apache.guacamole:guacamole-common (Maven): affected all versions; fixed in 1.0.0\n- org.apache.guacamole:guacamole-common (Maven): affected all versions; fixed in 1.0.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2018-1340/ (Markdown: https://insights.sbomify.com/CVE-2018-1340/index.md)","id":"CVE-2018-1340","markdown":"https://insights.sbomify.com/CVE-2018-1340/index.md","name":"CVE-2018-1340","record":{"aliases":["GHSA-wr7r-vg3c-54r5","UBUNTU-CVE-2018-1340"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_read","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Apache Guacamole","requires_auth":"none","summary":"An attacker can intercept session tokens via unencrypted HTTP requests due to a missing secure flag on cookies, potentially leading to account takeover.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"guacamole","vendor":"apache"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N","version":"3.0"},"cwes":[{"id":"CWE-311","name":"Missing Encryption of Sensitive Data"}],"description":"Prior to 1.0.0, Apache Guacamole used a cookie for client-side storage of the user's session token. This cookie lacked the \"secure\" flag, which could allow an attacker eavesdropping on the network to intercept the user's session token if unencrypted HTTP requests are made to the same domain.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Missing Encryption of Sensitive Data in Apache Guacamole","id":"CVE-2018-1340","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"information_disclosure","year":"2018"},"n_packages":2,"n_references":2,"next":{"headline":"File upload in NetIQ Access Manager, Administrative Console","id":"CVE-2018-1342"},"packages":[{"ecosystem":"Maven","fixed":["1.0.0"],"introduced":["0"],"last_affected":[],"package":"org.apache.guacamole:guacamole-common","purl":null,"source":"GHSA-wr7r-vg3c-54r5"},{"ecosystem":"Maven","fixed":["1.0.0"],"introduced":["0"],"last_affected":[],"package":"org.apache.guacamole:guacamole-common","purl":"pkg:maven/org.apache.guacamole/guacamole-common","source":"GHSA-wr7r-vg3c-54r5"}],"prev":{"headline":"org.apache.tika:tika-parsers has an Infinite Loop vulnerability","id":"CVE-2018-1339"},"products":["Apache Guacamole"],"published":"2019-02-07","related":[{"cvss_score":8.8,"headline":"Improper validation of SAML responses","id":"CVE-2021-43999","kev_date_added":null,"published":"2022-01-11"},{"cvss_score":8.1,"headline":"Apache Guacamole Race Condition vulnerability","id":"CVE-2017-3158","kev_date_added":null,"published":"2018-01-18"},{"cvss_score":7.5,"headline":"Apache Guacamole: Integer overflow in handling of VNC image buffers","id":"CVE-2023-43826","kev_date_added":null,"published":"2023-12-19"},{"cvss_score":7.5,"headline":"Null dereference in n/a","id":"CVE-2019-19603","kev_date_added":null,"published":"2019-12-09"},{"cvss_score":6.8,"headline":"Apache Guacamole: Improper input validation of console codes","id":"CVE-2024-35164","kev_date_added":null,"published":"2025-07-02"},{"cvss_score":6.8,"headline":"Apache Guacamole: Use-after-free in handling of RDP audio input buffer","id":"CVE-2023-30576","kev_date_added":null,"published":"2023-06-07"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-16","vendors":["Apache Software Foundation"]},"summary":"An attacker can intercept session tokens via unencrypted HTTP requests due to a missing secure flag on cookies, potentially leading to account takeover.","url":"https://insights.sbomify.com/CVE-2018-1340/"}