# CVE-2018-1340: Missing Encryption of Sensitive Data in Apache Guacamole

> An attacker can intercept session tokens via unencrypted HTTP requests due to a missing secure flag on cookies, potentially leading to account takeover.

- **Severity:** High 7.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Feb 2019
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-wr7r-vg3c-54r5, UBUNTU-CVE-2018-1340

## What is CVE-2018-1340?

CVE-2018-1340 is a high-severity vulnerability in Apache Guacamole, published on 7 Feb 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Prior to 1.0.0, Apache Guacamole used a cookie for client-side storage of the user's session token. This cookie lacked the "secure" flag, which could allow an attacker eavesdropping on the network to intercept the user's session token if unencrypted HTTP requests are made to the same domain.

Weakness: CWE-311 (Missing Encryption of Sensitive Data)

## Which versions are affected by CVE-2018-1340?

2 open source packages ship an affected version, including org.apache.guacamole:guacamole-common. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.guacamole:guacamole-common` | Maven | All versions | 1.0.0 |
| `org.apache.guacamole:guacamole-common` | Maven | All versions | 1.0.0 |

Products: Apache Guacamole.

## How do I fix CVE-2018-1340?

Upgrade org.apache.guacamole:guacamole-common to 1.0.0 or later.

## Is CVE-2018-1340 being exploited?

There is no known exploitation of CVE-2018-1340 in the wild and no public exploit code.

## Other vulnerabilities in Apache Guacamole

- [CVE-2021-43999](https://insights.sbomify.com/CVE-2021-43999/): Improper validation of SAML responses (high 8.8)
- [CVE-2017-3158](https://insights.sbomify.com/CVE-2017-3158/): Apache Guacamole Race Condition vulnerability (high 8.1)
- [CVE-2023-43826](https://insights.sbomify.com/CVE-2023-43826/): Apache Guacamole: Integer overflow in handling of VNC image buffers (high 7.5)
- [CVE-2019-19603](https://insights.sbomify.com/CVE-2019-19603/): Null dereference in n/a (high 7.5)
- [CVE-2024-35164](https://insights.sbomify.com/CVE-2024-35164/): Apache Guacamole: Improper input validation of console codes (medium 6.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-1340 and fix it if it is affected.

What it is: CVE-2018-1340 is a high-severity vulnerability in Apache Guacamole, published on 7 Feb 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-1340 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.guacamole:guacamole-common (Maven): affected all versions; fixed in 1.0.0
- org.apache.guacamole:guacamole-common (Maven): affected all versions; fixed in 1.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-1340/ (Markdown: https://insights.sbomify.com/CVE-2018-1340/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-1340
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-1340
- OSV: https://osv.dev/vulnerability/CVE-2018-1340

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-1340/
Summaries are generated and may contain mistakes; the official description above is the record.
