# CVE-2018-13447: Dolibarr SQL injection vulnerability in product/card.php

> Remote attackers can execute arbitrary SQL commands via the statut parameter in Dolibarr ERP/CRM, potentially compromising database integrity and confidentiality.

- **Severity:** Critical 9.8 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Jul 2018
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-jjqq-m998-53jf, UBUNTU-CVE-2018-13447

## What is CVE-2018-13447?

CVE-2018-13447 is a critical SQL injection vulnerability in Dolibarr Dolibarr Erp\/Crm, published on 8 Jul 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

SQL injection vulnerability in product/card.php in Dolibarr ERP/CRM version 7.0.3 allows remote attackers to execute arbitrary SQL commands via the statut parameter.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2018-13447?

2 open source packages ship an affected version, including dolibarr/dolibarr. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `dolibarr/dolibarr` | Packagist | From 7.0.3 | 7.0.4 |
| `dolibarr/dolibarr` | Packagist | From 7.0.3 | 7.0.4 |

Products: Dolibarr Dolibarr Erp\/Crm.

## How do I fix CVE-2018-13447?

Upgrade dolibarr/dolibarr to 7.0.4 or later.

## Is CVE-2018-13447 being exploited?

There is no known exploitation of CVE-2018-13447 in the wild and no public exploit code.

## Other vulnerabilities in Dolibarr Dolibarr Erp\/Crm

- [CVE-2022-43138](https://insights.sbomify.com/CVE-2022-43138/): Dolibarr vulnerable to privilege escalation (critical 9.8)
- [CVE-2022-40871](https://insights.sbomify.com/CVE-2022-40871/): Dolibarr vulnerable to Eval Injection (critical 9.8)
- [CVE-2021-33816](https://insights.sbomify.com/CVE-2021-33816/): Dolibarr remote PHP code execution (critical 9.8)
- [CVE-2020-7995](https://insights.sbomify.com/CVE-2020-7995/): Dolibarr Improper Restriction of Excessive Authentication Attempts (critical 9.8)
- [CVE-2013-2091](https://insights.sbomify.com/CVE-2013-2091/): SQL injection in dolibarr (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-13447 and fix it if it is affected.

What it is: CVE-2018-13447 is a critical SQL injection vulnerability in Dolibarr Dolibarr Erp\/Crm, published on 8 Jul 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-13447 in the wild and no public exploit code.

Affected packages and fixed versions:
- dolibarr/dolibarr (Packagist): affected from 7.0.3; fixed in 7.0.4
- dolibarr/dolibarr (Packagist): affected from 7.0.3; fixed in 7.0.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-13447/ (Markdown: https://insights.sbomify.com/CVE-2018-13447/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-13447
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-13447
- OSV: https://osv.dev/vulnerability/CVE-2018-13447

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-13447/
Summaries are generated and may contain mistakes; the official description above is the record.
