{"answers":{"affected":"3 open source packages ship an affected version, including mailman. It affects 1 product.","exploited":"There is no known exploitation of CVE-2018-13796 in the wild and no public exploit code.","fix":"Upgrade mailman to 2.1.28 or later.","what":"CVE-2018-13796 is a medium-severity cross-site scripting vulnerability in n/a, published on 12 Jul 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2018-13796 and fix it if it is affected.\n\nWhat it is: CVE-2018-13796 is a medium-severity cross-site scripting vulnerability in n/a, published on 12 Jul 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2018-13796 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- mailman (PyPI): affected all versions; fixed in 2.1.28\n- mailman (PyPI): affected all versions; fixed in 2.1.28\n- mailman (PyPI): affected all versions; fixed in 2.1.28\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2018-13796/ (Markdown: https://insights.sbomify.com/CVE-2018-13796/index.md)","id":"CVE-2018-13796","markdown":"https://insights.sbomify.com/CVE-2018-13796/index.md","name":"CVE-2018-13796","record":{"aliases":["GHSA-xqvg-xm9m-p2c4","MGASA-2018-0383","PYSEC-2026-661","UBUNTU-CVE-2018-13796"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_read","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"GNU Mailman","requires_auth":"none","summary":"Attackers can inject arbitrary text into web pages via crafted URLs, potentially misleading users on trusted Mailman sites.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"mailman","vendor":"gnu"}],"cvss":{"score":6.5,"severity":"medium","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N","version":"3.0"},"cwes":[{"id":"CWE-20","name":"Improper Input Validation"}],"description":"An issue was discovered in GNU Mailman before 2.1.28. A crafted URL can cause arbitrary text to be displayed on a web page from a trusted site.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Moderate severity vulnerability that affects mailman","id":"CVE-2018-13796","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"xss","year":"2018"},"n_packages":3,"n_references":5,"next":{"headline":"Command Injection in macaddress","id":"CVE-2018-13797"},"packages":[{"ecosystem":"PyPI","fixed":["2.1.28"],"introduced":["0"],"last_affected":[],"package":"mailman","purl":null,"source":"GHSA-xqvg-xm9m-p2c4"},{"ecosystem":"PyPI","fixed":["2.1.28"],"introduced":["0"],"last_affected":[],"package":"mailman","purl":"pkg:pypi/mailman","source":"GHSA-xqvg-xm9m-p2c4"},{"ecosystem":"PyPI","fixed":["2.1.28"],"introduced":["0"],"last_affected":[],"package":"mailman","purl":"pkg:pypi/mailman","source":"PYSEC-2026-661"}],"prev":{"headline":"Denial of service in n/a","id":"CVE-2018-13795"},"products":["n/a"],"published":"2018-07-12","related":[{"cvss_score":8.8,"headline":"Cross-site request forgery in n/a","id":"CVE-2016-6893","kev_date_added":null,"published":"2016-09-02"},{"cvss_score":8.8,"headline":"Cross-site request forgery in n/a","id":"CVE-2016-7123","kev_date_added":null,"published":"2016-09-02"},{"cvss_score":7.8,"headline":"Denial of service in n/a","id":"CVE-2005-4153","kev_date_added":null,"published":"2005-12-11"},{"cvss_score":7.5,"headline":"Other in n/a","id":"CVE-2006-2191","kev_date_added":null,"published":"2006-09-19"},{"cvss_score":7.5,"headline":"Weak cryptography in n/a","id":"CVE-2004-1143","kev_date_added":null,"published":"2005-01-19"},{"cvss_score":7.5,"headline":"Cross-site scripting in n/a","id":"CVE-2002-0855","kev_date_added":null,"published":"2002-08-14"},{"cvss_score":7.5,"headline":"Auth bypass in n/a","id":"CVE-2001-1132","kev_date_added":null,"published":"2002-06-25"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"Attackers can inject arbitrary text into web pages via crafted URLs, potentially misleading users on trusted Mailman sites.","url":"https://insights.sbomify.com/CVE-2018-13796/"}