# CVE-2018-13796: Moderate severity vulnerability that affects mailman

> Attackers can inject arbitrary text into web pages via crafted URLs, potentially misleading users on trusted Mailman sites.

- **Severity:** Medium 6.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 12 Jul 2018
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-xqvg-xm9m-p2c4, MGASA-2018-0383, PYSEC-2026-661, UBUNTU-CVE-2018-13796

## What is CVE-2018-13796?

CVE-2018-13796 is a medium-severity cross-site scripting vulnerability in n/a, published on 12 Jul 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

An issue was discovered in GNU Mailman before 2.1.28. A crafted URL can cause arbitrary text to be displayed on a web page from a trusted site.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2018-13796?

3 open source packages ship an affected version, including mailman. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mailman` | PyPI | All versions | 2.1.28 |
| `mailman` | PyPI | All versions | 2.1.28 |
| `mailman` | PyPI | All versions | 2.1.28 |

Products: Gnu Mailman.

## How do I fix CVE-2018-13796?

Upgrade mailman to 2.1.28 or later.

## Is CVE-2018-13796 being exploited?

There is no known exploitation of CVE-2018-13796 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2016-6893](https://insights.sbomify.com/CVE-2016-6893/): Cross-site request forgery in n/a (high 8.8)
- [CVE-2016-7123](https://insights.sbomify.com/CVE-2016-7123/): Cross-site request forgery in n/a (high 8.8)
- [CVE-2005-4153](https://insights.sbomify.com/CVE-2005-4153/): Denial of service in n/a (high 7.8)
- [CVE-2006-2191](https://insights.sbomify.com/CVE-2006-2191/): Other in n/a (high 7.5)
- [CVE-2004-1143](https://insights.sbomify.com/CVE-2004-1143/): Weak cryptography in n/a (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-13796 and fix it if it is affected.

What it is: CVE-2018-13796 is a medium-severity cross-site scripting vulnerability in n/a, published on 12 Jul 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2018-13796 in the wild and no public exploit code.

Affected packages and fixed versions:
- mailman (PyPI): affected all versions; fixed in 2.1.28
- mailman (PyPI): affected all versions; fixed in 2.1.28
- mailman (PyPI): affected all versions; fixed in 2.1.28

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-13796/ (Markdown: https://insights.sbomify.com/CVE-2018-13796/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-13796
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-13796
- OSV: https://osv.dev/vulnerability/CVE-2018-13796

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-13796/
Summaries are generated and may contain mistakes; the official description above is the record.
