# CVE-2018-13797: Command Injection in macaddress


- **Severity:** Critical 9.8 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 10 Jul 2018
- **Updated:** 16 Sep 2024
- **Also known as:** DEBIAN-CVE-2018-13797, GHSA-pp57-mqmh-44h7, UBUNTU-CVE-2018-13797

## What is CVE-2018-13797?

CVE-2018-13797 is a critical vulnerability in n/a, published on 10 Jul 2018. 

### Official description

The macaddress module before 0.2.9 for Node.js is prone to an arbitrary command injection flaw, due to allowing unsanitized input to an exec (rather than execFile) call.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2018-13797?

2 open source packages ship an affected version, including macaddress. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `macaddress` | npm | All versions | 0.2.9 |
| `macaddress` | npm | All versions | 0.2.9 |

Products: Node-Macaddress Project Node-Macaddress.

## How do I fix CVE-2018-13797?

Upgrade macaddress to 0.2.9 or later.

## Is CVE-2018-13797 being exploited?

There is no known exploitation of CVE-2018-13797 in the wild and no public exploit code.

Public exploit code:

- https://github.com/dsp-testing/CVE-2018-13797 (github_poc): https://github.com/dsp-testing/CVE-2018-13797

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-13797 and fix it if it is affected.

What it is: CVE-2018-13797 is a critical vulnerability in n/a, published on 10 Jul 2018. 
Exploitation: There is no known exploitation of CVE-2018-13797 in the wild and no public exploit code.

Affected packages and fixed versions:
- macaddress (npm): affected all versions; fixed in 0.2.9
- macaddress (npm): affected all versions; fixed in 0.2.9

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-13797/ (Markdown: https://insights.sbomify.com/CVE-2018-13797/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-13797
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-13797
- OSV: https://osv.dev/vulnerability/CVE-2018-13797

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-13797/
Summaries are generated and may contain mistakes; the official description above is the record.
