CVE-2018-14040 Bootstrap vulnerable to Cross-Site Scripting (XSS)
Cross-site scripting vulnerability in Bootstrap allows attackers to execute arbitrary scripts via the collapse data-parent attribute.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2018-14040?
CVE-2018-14040 is a medium-severity cross-site scripting vulnerability in Debian Debian Linux, published on 13 Jul 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
In Bootstrap before 4.1.2, XSS is possible in the collapse data-parent attribute.
Weakness: CWE-79
Which versions are affected by CVE-2018-14040?
24 open source packages ship an affected version, including bootstrap, org.webjars:bootstrap and bootstrap.sass. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
bootstrap NuGet | From 2.3.0 | 3.4.0 |
bootstrap NuGet | From 2.3.0 | 3.4.0 |
bootstrap NuGet | From 4.0.0 | 4.1.2 |
bootstrap NuGet | From 4.0.0 | 4.1.2 |
bootstrap RubyGems | From 2.3.0 | 3.4.0 |
bootstrap RubyGems | From 2.3.0 | 3.4.0 |
18 more packages
bootstrap RubyGems | From 4.0.0 | 4.1.2 |
bootstrap RubyGems | From 4.0.0 | 4.1.2 |
bootstrap npm | From 2.3.0 | 3.4.0 |
bootstrap npm | From 2.3.0 | 3.4.0 |
bootstrap npm | From 4.0.0 | 4.1.2 |
bootstrap npm | From 4.0.0 | 4.1.2 |
org.webjars:bootstrap Maven | From 2.3.0 | 3.4.0 |
org.webjars:bootstrap Maven | From 2.3.0 | 3.4.0 |
org.webjars:bootstrap Maven | From 4.0.0 | 4.1.2 |
org.webjars:bootstrap Maven | From 4.0.0 | 4.1.2 |
bootstrap.sass NuGet | From 4.0.0 | 4.1.2 |
bootstrap.sass NuGet | From 4.0.0 | 4.1.2 |
twbs/bootstrap Packagist | From 2.3.0 | 3.4.0 |
twbs/bootstrap Packagist | From 2.3.0 | 3.4.0 |
twbs/bootstrap Packagist | From 4.0.0 | 4.1.2 |
twbs/bootstrap Packagist | From 4.0.0 | 4.1.2 |
bootstrap-sass RubyGems | From 2.3.0 | 3.4.0 |
bootstrap-sass RubyGems | From 2.3.0 | 3.4.0 |
Products include Debian Debian Linux, Getbootstrap Bootstrap.
How do I fix CVE-2018-14040?
Upgrade bootstrap to a fixed version for your release line: 3.4.0 or 4.1.2.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2018-14040 being exploited?
There is no known exploitation of CVE-2018-14040 in the wild and no public exploit code.
Public exploit code: 2 proofs of concept on GitHub.
Other vulnerabilities in Debian Debian Linux
Sources
Also known as AZL-13232, AZL-43750, AZL-44334, DEBIAN-CVE-2018-14040, DLA-1479-1, GHSA-3wqf-4x89-9g79 and 1 more.