CVE-2018-14042 Bootstrap Cross-site Scripting vulnerability
Cross-site scripting vulnerability in Bootstrap tooltip component allows attackers to execute arbitrary scripts in user browsers.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2018-14042?
CVE-2018-14042 is a medium-severity cross-site scripting vulnerability in n/a, published on 13 Jul 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
In Bootstrap before 4.1.2, XSS is possible in the data-container property of tooltip.
Weakness: CWE-79
Which versions are affected by CVE-2018-14042?
26 open source packages ship an affected version, including bootstrap, org.webjars:bootstrap and bootstrap.sass. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
bootstrap NuGet | From 2.3.0 | 3.4.0 |
bootstrap NuGet | From 2.3.0 | 3.4.0 |
bootstrap NuGet | From 4.0.0 | 4.1.2 |
bootstrap NuGet | From 4.0.0 | 4.1.2 |
bootstrap RubyGems | From 2.3.0 | 3.4.0 |
bootstrap RubyGems | From 2.3.0 | 3.4.0 |
20 more packages
bootstrap RubyGems | From 4.0.0 | 4.1.2 |
bootstrap RubyGems | From 4.0.0 | 4.1.2 |
bootstrap npm | From 2.3.0 | 3.4.0 |
bootstrap npm | From 2.3.0 | 3.4.0 |
bootstrap npm | From 4.0.0 | 4.1.2 |
bootstrap npm | From 4.0.0 | 4.1.2 |
org.webjars:bootstrap Maven | From 2.3.0 | 3.4.0 |
org.webjars:bootstrap Maven | From 2.3.0 | 3.4.0 |
org.webjars:bootstrap Maven | From 4.0.0 | 4.1.2 |
org.webjars:bootstrap Maven | From 4.0.0 | 4.1.2 |
bootstrap.sass NuGet | From 4.0.0 | 4.1.2 |
bootstrap.sass NuGet | From 4.0.0 | 4.1.2 |
twbs/bootstrap Packagist | From 2.3.0 | 3.4.0 |
twbs/bootstrap Packagist | From 2.3.0 | 3.4.0 |
twbs/bootstrap Packagist | From 4.0.0 | 4.1.2 |
twbs/bootstrap Packagist | From 4.0.0 | 4.1.2 |
bootstrap-sass RubyGems | From 2.3.0 | 3.4.0 |
bootstrap-sass RubyGems | From 2.3.0 | 3.4.0 |
bootstrap-sass npm | From 2.0.4 | 3.4.0 |
bootstrap-sass npm | From 2.0.4 | 3.4.0 |
Products include Getbootstrap Bootstrap.
How do I fix CVE-2018-14042?
Upgrade bootstrap to a fixed version for your release line: 3.4.0 or 4.1.2.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2018-14042 being exploited?
There is no known exploitation of CVE-2018-14042 in the wild and no public exploit code.
Public exploit code: 1 proofs of concept on GitHub.
Other vulnerabilities in n/a
Sources
Also known as AZL-105143, AZL-105152, AZL-105269, AZL-44094, DEBIAN-CVE-2018-14042, GHSA-7mvr-5x2g-wfc8 and 1 more.