{"answers":{"affected":"2 open source packages ship an affected version, including pimcore/pimcore. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2018-14058 exists.","fix":"Upgrade pimcore/pimcore to 5.3.0 or later.","what":"CVE-2018-14058 is a medium-severity SQL injection vulnerability in Pimcore Pimcore, published on 17 Aug 2018. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2018-14058 and fix it if it is affected.\n\nWhat it is: CVE-2018-14058 is a medium-severity SQL injection vulnerability in Pimcore Pimcore, published on 17 Aug 2018. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2018-14058 exists.\n\nAffected packages and fixed versions:\n- pimcore/pimcore (Packagist): affected all versions; fixed in 5.3.0\n- pimcore/pimcore (Packagist): affected all versions; fixed in 5.3.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2018-14058/ (Markdown: https://insights.sbomify.com/CVE-2018-14058/index.md)","id":"CVE-2018-14058","markdown":"https://insights.sbomify.com/CVE-2018-14058/index.md","name":"CVE-2018-14058","record":{"aliases":["GHSA-q4hw-c66h-4xqc"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_read","data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"Pimcore CMS","requires_auth":"low_privilege","summary":"Attackers can execute arbitrary SQL commands via the REST API, potentially reading or modifying database contents.","user_interaction":"not_required","vuln_class":"sql_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"pimcore","vendor":"pimcore"}],"cvss":{"score":6.5,"severity":"medium","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N","version":"3.0"},"cwes":[{"id":"CWE-89","name":"Improper Neutralization of Special Elements used in an SQL Command"}],"description":"Pimcore before 5.3.0 allows SQL Injection via the REST web service API.","ecosystems":["Packagist"],"exploits":{"exploitdb":3,"first_seen":"2018-08-13","github_poc":0,"max_poc_stars":null,"metasploit":1,"nuclei":0,"refs":[{"date":"2018-08-13","kind":"metasploit","ref":"auxiliary/gather/pimcore_creds_sqli","stars":null,"title":"Pimcore Gather Credentials via SQL Injection"},{"date":"2018-08-16","kind":"exploitdb","ref":"45208","stars":null,"title":"Pimcore 5.2.3 - SQL Injection / Cross-Site Scripting / Cross-Site Request Forgery"},{"date":"2018-08-16","kind":"exploitdb","ref":"45208","stars":null,"title":"Pimcore 5.2.3 - SQL Injection / Cross-Site Scripting / Cross-Site Request Forgery"},{"date":"2018-08-16","kind":"exploitdb","ref":"45208","stars":null,"title":"Pimcore 5.2.3 - SQL Injection / Cross-Site Scripting / Cross-Site Request Forgery"}],"tier":"weaponised"},"has_fix":true,"headline":"Pimcore SQLi Vulnerability","id":"CVE-2018-14058","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":"pimcore:pimcore","products":["pimcore:pimcore"],"type":"sql_injection","year":"2018"},"n_packages":2,"n_references":4,"next":{"headline":"Pimcore XSS Vulnerability","id":"CVE-2018-14059"},"packages":[{"ecosystem":"Packagist","fixed":["5.3.0"],"introduced":["0"],"last_affected":[],"package":"pimcore/pimcore","purl":null,"source":"GHSA-q4hw-c66h-4xqc"},{"ecosystem":"Packagist","fixed":["5.3.0"],"introduced":["0"],"last_affected":[],"package":"pimcore/pimcore","purl":"pkg:composer/pimcore/pimcore","source":"GHSA-q4hw-c66h-4xqc"}],"prev":{"headline":"Pimcore CSRF Vulnerability","id":"CVE-2018-14057"},"products":["n/a"],"published":"2018-08-17","related":[{"cvss_score":9.8,"headline":"RCE vulnerability in Pimcore/Mail \u0026 Dynamic Text Layout","id":"CVE-2022-39365","kev_date_added":null,"published":"2022-10-27"},{"cvss_score":9.8,"headline":"Pimcore Access Control Issues","id":"CVE-2019-18981","kev_date_added":null,"published":"2019-11-15"},{"cvss_score":9.8,"headline":"Pimcore 2FA Vulnerable to Brute Forcing","id":"CVE-2019-18985","kev_date_added":null,"published":"2019-11-15"},{"cvss_score":8.8,"headline":"Pimcore has a Blind SQL Injection in Admin Search Find API due to an incomplete fix for CVE-2023-30848","id":"CVE-2026-23492","kev_date_added":null,"published":"2026-01-14"},{"cvss_score":8.8,"headline":"SQL Injection in Admin Grid Filter API in Pimcore","id":"CVE-2023-47637","kev_date_added":null,"published":"2023-11-15"},{"cvss_score":8.8,"headline":"Pimcore SQL Injection Vulnerability in Admin Search Find API","id":"CVE-2023-30848","kev_date_added":null,"published":"2023-04-27"},{"cvss_score":8.8,"headline":"Pimcore vulnerable to SQL Injection in Translation Export API","id":"CVE-2023-30849","kev_date_added":null,"published":"2023-04-27"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"attribution","licence":"BSD-3-Clause","name":"Metasploit"},{"class":"attribution","licence":"GPL-2.0-or-later","name":"Exploit-DB"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"Attackers can execute arbitrary SQL commands via the REST API, potentially reading or modifying database contents.","url":"https://insights.sbomify.com/CVE-2018-14058/"}