# CVE-2018-14371: Path Traversal in Eclipse Mojarra

> Remote attackers can exploit a directory traversal flaw in Eclipse Mojarra to download sensitive configuration files or Java bytecodes from applications.

- **Severity:** High 7.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Jul 2018
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-43q7-q5vp-3g68, UBUNTU-CVE-2018-14371

## What is CVE-2018-14371?

CVE-2018-14371 is a high-severity path traversal vulnerability in n/a, published on 18 Jul 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The getLocalePrefix function in ResourceManager.java in Eclipse Mojarra before 2.3.7 is affected by Directory Traversal via the loc parameter. A remote attacker can download configuration files or Java bytecodes from applications.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2018-14371?

2 open source packages ship an affected version, including org.glassfish:mojarra-parent. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.glassfish:mojarra-parent` | Maven | All versions | 2.3.7 |
| `org.glassfish:mojarra-parent` | Maven | All versions | 2.3.7 |

Products: Eclipse Mojarra.

## How do I fix CVE-2018-14371?

Upgrade org.glassfish:mojarra-parent to 2.3.7 or later.

## Is CVE-2018-14371 being exploited?

There is no known exploitation of CVE-2018-14371 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2026-46581](https://insights.sbomify.com/CVE-2026-46581/): Server-side request forgery in Eclipse Mojarra (high 7.5)
- [CVE-2020-6950](https://insights.sbomify.com/CVE-2020-6950/): Directory traversal in Eclipse Mojarra (medium 6.5)
- [CVE-2019-17091](https://insights.sbomify.com/CVE-2019-17091/): Cross-site Scripting in Eclipse Mojarra (medium 6.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-14371 and fix it if it is affected.

What it is: CVE-2018-14371 is a high-severity path traversal vulnerability in n/a, published on 18 Jul 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-14371 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.glassfish:mojarra-parent (Maven): affected all versions; fixed in 2.3.7
- org.glassfish:mojarra-parent (Maven): affected all versions; fixed in 2.3.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-14371/ (Markdown: https://insights.sbomify.com/CVE-2018-14371/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-14371
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-14371
- OSV: https://osv.dev/vulnerability/CVE-2018-14371

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-14371/
Summaries are generated and may contain mistakes; the official description above is the record.
