# CVE-2018-14505: Mitmweb in mitmproxy allows DNS Rebinding attacks

> Attackers can exploit DNS rebinding in mitmweb to bypass same-origin policies and access internal resources or sensitive data.

- **Severity:** High 8.8 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 22 Jul 2018
- **Updated:** 5 Aug 2024
- **Also known as:** DEBIAN-CVE-2018-14505, GHSA-6m53-c78q-7qmg, PYSEC-2018-56, UBUNTU-CVE-2018-14505

## What is CVE-2018-14505?

CVE-2018-14505 is a high-severity server-side request forgery vulnerability in n/a, published on 22 Jul 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

mitmweb in mitmproxy v4.0.3 allows DNS Rebinding attacks, related to tools/web/app.py.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2018-14505?

3 open source packages ship an affected version, including mitmproxy. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mitmproxy` | PyPI | All versions | 4.0.4 |
| `mitmproxy` | PyPI | All versions | 4.0.4 |
| `mitmproxy` | PyPI | All versions | 4.0.4 |

Products: Mitmproxy Mitmproxy.

## How do I fix CVE-2018-14505?

Upgrade mitmproxy to 4.0.4 or later.

## Is CVE-2018-14505 being exploited?

There is no known exploitation of CVE-2018-14505 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2022-24766](https://insights.sbomify.com/CVE-2022-24766/): Insufficient Protection against HTTP Request Smuggling in mitmproxy (critical 9.8)
- [CVE-2021-39214](https://insights.sbomify.com/CVE-2021-39214/): Lacking Protection against HTTP Request Smuggling in mitmproxy (high 8.1)
- [CVE-2026-40606](https://insights.sbomify.com/CVE-2026-40606/): ProxyAuth Addon LDAP Injection in mitmproxy (medium 4.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-14505 and fix it if it is affected.

What it is: CVE-2018-14505 is a high-severity server-side request forgery vulnerability in n/a, published on 22 Jul 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2018-14505 in the wild and no public exploit code.

Affected packages and fixed versions:
- mitmproxy (PyPI): affected all versions; fixed in 4.0.4
- mitmproxy (PyPI): affected all versions; fixed in 4.0.4
- mitmproxy (PyPI): affected all versions; fixed in 4.0.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-14505/ (Markdown: https://insights.sbomify.com/CVE-2018-14505/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-14505
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-14505
- OSV: https://osv.dev/vulnerability/CVE-2018-14505

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-14505/
Summaries are generated and may contain mistakes; the official description above is the record.
